I have Parallels 8 and Windows 7, and the copy and paste does not work. I called Parallels tech support and they had no answer on how to fix the problem. Does anyone else out there have a suggestion as to how to fix this problem?

  • Is it the keyboard shortcuts that do not work? - and you're sure it is Parallels 8? Parallels 7 is known to have this problem. – cutrightjm Sep 24 '12 at 1:43
  • Yes I am sure it is Parallels 8, I updated from 7 and the tech guy from parallels could not fix the issue. Yes it is the keyboard short cuts but it is also the right click and drop down list, techsupport tried everything, my drag and drop did start working but that is just not the same as copy and paste. – Anna Sep 24 '12 at 1:57
  • Add this as a comment, not an answer please. Also, did you UPDATE, or reinstall parallels? The issue from Parallels 7 could still be affecting you if it was just an update. – cutrightjm Sep 24 '12 at 2:09
  • When I made these changes it worked one time, after I restarted the windows side, I even tried to reboot the Macintosh but once is all it would work with the change. – Anna Sep 24 '12 at 2:48
  • After the fix it only worked one time and then the same issue copy and paste not working between the systems – Anna Sep 24 '12 at 2:51

Sometimes selecting "Virtual Machine - Reinstall parallels tools" helps.

Had this issue with both Parallels 7 and 8 (but my VM is Windows 8).

| improve this answer | |

Ok I was able to fix the issue in Parallels 8 copy and paste. You have to go to preferences, click on Options, click on advanced, click TIME: change to sync from either OS

| improve this answer | |
  • Bizarre, but that worked for me too. It just seems to kick start the feature, because afterwards I could set it back to "Sync from Mac OS X" and copy & paste still works. – meyertee Mar 31 '13 at 15:49

I have the same problem but with WinXP instead of Windows 7, and I have found that when copy-paste stops working, restarting the Parallels Tools service from the (WinXP) control panel makes it work again.

See also the instructions on the parallels site:

you should have Parallels Tools installed in the virtual machine, the Isolate Mac from Windows option disabled in the Security pane, and the Share Mac clipboard and Preserve text formatting options enabled in the Advanced pane.

| improve this answer | |

For Windows 8 and Parallels 8:

  1. Open the Configuration options from the Virtual machine menu.

  2. Under Security enable the "Isolate Mac from Windows" option (otherwise the copy and paste will never work).

  3. Under Advanced enable "Share MAC clipboard"

Note: In previous versions of Parallels Copy and Paste would work with "Isolate Mac from Windows" option disabled (my preferred choice) but this seems no longer to be the case.

You can still isolate the MAC...

  1. Under Sharing select:

    • Share folders: None
    • Disable: Access windows folders from MAC
  2. Under Applications select:

    • Disable: Share windows apps with MAC
    • Disable: Share MAC apps with Windows

Note: I prefer to isolate the MAC from Windows and only use network sharing when sharing files. This prevents any potential viruses from being able to access your mac files.

| improve this answer | |

I have found that copy and paste in my case were affected by Zonealarm firewall. Apparently Zonealarms web security was dumping my clipboard as a safety precaution. It would allow me to copy and paste sporadically after it dumped my clipboard. I believe there are other safety programs doing the same thing so check all your programs that try to protect you by keeping your clipboard clean. Hope this helps someone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.