I currently have Windows 8 32-bit installed from MSDN (I didn't realise at the time that my processor supports 64-bit).

I understand that you can't upgrade within Windows 32-bit to 64-bit directly from the ISO.

I have burned the ISO to a DVD, and have attempted booting from this drive.

The problem I am encountering:

The operating system couldn't be loaded because a required file is missing or contains errors.

File: CI.dll

Error code: 0xc0000221

You'll need to use the recovery tools on your installation media. If you don't have any installation media (like a disc or USB device), contact your system administrator or PC manufacturer.

Additional info:

  • Computer: HP Pavillion m9280.uk-a
  • Processor: AMD Phenom 9600 Quad-Core
  • RAM: 3 1GB sticks

Thanks in advance!

  • Try running the Windows setup program on the DVD you burned rather than booting it. – martineau Sep 24 '12 at 10:10
  • 1
    Based on the error it seems your boot disk ( the dvd you created ) is not actually bootable. This indicates the iso is actually corrupt. I would wipe the Windows installation before trying to boot to x64 windows installer. – Ramhound Sep 24 '12 at 10:46
  • @martineau I can't run the setup on the DVD because it's in 64-bit format, and my computer currently has 32-bit Win8 installed. – Andrew Gee Sep 24 '12 at 13:39
  • @Ramhound How would you suggest wiping the Windows installation? – Andrew Gee Sep 24 '12 at 13:40
  • @Andrew Gee: Can you run the 32-bit installer again and format the existing partition from there (and then quit before it starts copy the OS again)? – martineau Sep 24 '12 at 16:09

Download GParted, burn the LiveCD (or create a LiveUSB), then boot from it and repartition/format your HDD as required. Now boot from the Windows 8 DVD (or USB, which is much faster) and proceed with the installation. If you still get the error, recreate the install media from a known good source.

  • Thanks, this helped although it still didn't work. I had to install Windows 7 64-bit instead,.which worked fine. I might try Windows 8 later. – Andrew Gee Sep 24 '12 at 20:27

You might want to boot from a Linux rescue CD and scan the drive for malware because it may be down to something like this.

  • My computer is working normally with the 32-bit version of Windows 8, i.e. I don't get this error normally, only when trying to use my 64-bit DVD. – Andrew Gee Sep 24 '12 at 13:41

Right, so understanding that you used the Windows 7 USB/DVD Download Tool on a 32-bit PC to create a bootable disk for a 64-bit ISO, first of all you would have got an error at the end of the burning process saying that the bootable disk couldn't be created. To fix this problem, follow the steps listed on this site http://kyleabaker.com/2011/12/29/create-a-bootable-windows-7-x64-install-flash-drive-from-32-bit-window/

I can vouch for this site that the solution given here works because I had the exact same problem. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.