85

When there are very tall cells in Microsoft Excel, trying to scroll via mouse or even via scrollbar (clicking on "<-" "->" pointers) just jumps below to the next cell, hiding the bottom content of the large cell in question.

Is there an option to have Excel scroll smoothly?

So far I found only one way - click middle button on mouse - and scroll smoothly by moving mouse aside.

6
  • its not possible . its bug in excel 2007 if you are using vista
    – joe
    Sep 28, 2009 at 13:29
  • Yes, I'm on Vista now. And no Fixes available???
    – zmische
    Sep 29, 2009 at 6:53
  • 1
    FYI same issue/bug in OpenOffice calc, see this: qa.openoffice.org/issues/show_bug.cgi?id=7722 and this user.services.openoffice.org/en/forum/… It's a nightmare! Nov 11, 2010 at 14:01
  • 5
    FWIW, this is a usability issue with every version of Excel that I have ever used, and on various OS versions through the years.
    – Chris O
    Jul 7, 2014 at 13:17
  • I tend to click and drag the vertical scrollbar in this situation. It's not ideal as I have to hold the mouse button down to prevent it jumping around to "snap to cell" while reading, but I find it easier to control than the middle-mouse-button-drag technique. Jun 11, 2015 at 23:47

8 Answers 8

34

This is more of a design flaw in Excel than a bug. It's definitely a usability problem as it is super easy to scroll past a cell with it basically never showing in the view.

As much as I hate to suggest this (I hate this feature) you can middle-drag to scroll smoothly. Once you release/click again/move the mouse over top of the origin, Excel will snap the top of the view again.

This same problem is present in Office 2010 under Windows 7.

12
  • 3
    +1 for the solution. How do you middle-click/drag on a mac though?
    – Geo
    Jan 29, 2014 at 15:13
  • 1
    You might have luck using a PC mouse and making sure nothing is taking over the middle mouse button (like expose/mission control/dashboard)
    – Charlie
    Feb 1, 2014 at 0:34
  • 9
    I'm genuinely at a loss to why this is a built in feature that cannot be turned off. Fair enough, it might be useful for simple spreadsheets, but users always have large cells that they might want to scroll partly into view using the scroll bars but you can't do it. It's ridiculous!
    – theyetiman
    Apr 11, 2014 at 10:57
  • Excel's rendering code is highly optimized and extremely old. I imagine it is a total mess and re-writing it is not an option. Since it has snapped from the beginning, it continues to have that restriction.
    – Charlie
    Apr 11, 2014 at 20:23
  • 2
    Charlie, that would make sense if it was impossible to scroll smoothly, but it's not a problem with the rendering engine, because clearly you can scroll smoothly with middle mouse button. It's not like the grid is ridgidly fixed in the upper left and they're just shifting cell contents into that static grid. The middle mouse button smooth scrolling proves that's not the issue. This is simply a design flaw, in that the scrollbars always force it to jump to the next cell. The behavior could easily be switched off, they just don't make it an option.
    – Triynko
    Jul 3, 2014 at 20:02
9

This is a limitation of excel.
2 options...

  1. Change your cell height manually. Right click on the row number on the left side, choose row height. Don't use enormous cells.
  2. If it's only one cell, don't use one big cell, but instead merge a large # of cells vertically using "merge and center". This will allow a smooth scroll in relation to that newly merged cell.
2
  • 14
    I can't believe Excel and Calc have such a limitation. All my thoughts go to people needing these pieces of software on a daily basis...
    – m-ric
    Mar 19, 2013 at 14:22
  • 1
    indeed, it's a pain in the ***.
    – Bakaburg
    Oct 13, 2013 at 13:33
7

You won't be able to not scroll by rows, but you can minimize them to one row. Just change the mousewheel setting to 1, as per this link.

If you use the Scroll Lock button then using the arrow keys will move the screen instead of the cursor.

2
  • Scroll lock has the same limitation, unfortunately. Jun 18, 2013 at 19:15
  • +1 As you said, this does not address the issue and quite frankly renders the mouse wheel useless in other applications, but at least Excel no longer skips rows when I set the number of lines to 1.
    – cdonner
    May 7, 2014 at 17:25
2

You can also insert two blank rows between your large rows, then hide the blank rows. This will make excel act as though you changed your mouse line scroll to 1 line but not affect your other applications. This might not solve your entire need (if one large row doesn't even fit on one screen), but it will help a little.

0

You can make this change in Control Panel > Mouse settings.

To change the number of lines that you scroll in Excel:

  1. Open Mouse in Control Panel.
  2. On the Wheel tab, under Scrolling, click Scroll, and then select the number of lines to scroll with each notch on the wheel

In Windows 7, mine was set to 3 cells as default, and I was able to change this to 2 (or you can change it to 1 or any number). I guess the only constraint is that this will affect how the mouse works in ALL programmes.

1
  • same answer as Lance Roberts' from 3 years ago
    – cdonner
    May 7, 2014 at 17:24
0

My solution to this is to zoom out slightly to 90%, this seems to turn off the "feature" in Excel 2016 at least.

2
  • 2
    This doesn't work for me in Excel 2016 on PC. At 90% zoom, Excel still "snaps" to the nearest cell if I let go of the scroll bar when the middle of the cell is lined up with the top of the screen.
    – Barrie
    Aug 18, 2016 at 8:14
  • This doesn't actually fix it. It just makes the cells small enough that it isn't as annoying.
    – rollsch
    Oct 15, 2018 at 3:20
-1

Quick fix: right click on the column header and select:

Excel_column_width

2
  • I assume you meant to click on the row header and select Row Height, but then? Change it? To something smaller? Then I won't see the content of the cell anymore and have gained nothing.
    – cdonner
    May 7, 2014 at 17:27
  • @cdonner This can be done with rows also, yes. The 'gain' is that by decreasing the width of the column it is now (after shrinking) possible to decrease the size of the column further with a mouse (by just dragging the edge of the column) and thus at least partially see/scroll through multiple columns on the screen. The solution doesn't really implement smooth scrolling, that's why I've called it the quick fix.
    – colemik
    May 7, 2014 at 21:03
-2

See if you are able to scroll smoothly in other applications with the middle wheel. This will help determine if the problem is with Excel or your mouse.

If you can't scroll smoothly in other programs, you may want to check your mouse driver settings, update the driver, or both.

1
  • 6
    -1 for an answer so useless that I would expect to find it on a Microsoft forum, but not here.
    – cdonner
    May 7, 2014 at 17:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.