27

The "Show In Finder" action isn't working on Mac OS X Mountain Lion. The problem has just started to occur all the time, before it was a bit sporadic, but now it happens all the time.

Things that don't work:

  • In the chrome Downloads page clicking any of the "Show in Finder" links.
  • Right clicking a file in XCode and choosing "Show in Finder"

Things that work:

  • open . in terminal
  • command-n after command tabbing to Finder.

Things I've tried to fix the issue:

  • Opt - Right Click finder in the dock and relauching
  • Restarting my computer

Anybody ever experienced this issue?

6
  • Experienced it... but no idea how I solved it other than possibly through OS updates. Command-clicking a Dock icon will probably not work as well?
    – Daniel Beck
    Sep 25 '12 at 18:36
  • @DanielBeck Command-clicking a dock icon does work Sep 25 '12 at 18:43
  • Just wondering. Do you use TotalFinder? This might be related. Sep 29 '12 at 6:51
  • @Darwin nope. I don't use total finder. Sep 29 '12 at 20:37
  • I've seen it happen as well. Could it be that you're using Dropbox?
    – slhck
    Oct 27 '12 at 22:07
33

It is a bug introduced by Apple in 10.8.2.

Workaround: when it happens, in Terminal run the following:

sudo killall -KILL appleeventsd

Alternatively, use Activity Monitor to kill appleeventsd. More information on the issue.

10
  • 1
    This didn't work for me on 10.8.2.
    – Joe Mornin
    Nov 9 '12 at 18:32
  • 1
    Didn't work for me either. Nov 15 '12 at 20:50
  • 2
    Worked on 10.8.2. Would have accepted sooner, but stopped happening after I posted the question -- one day I will find Murphy and slap him with a piece of peanut butter toast. Peanut butter side up! Nov 19 '12 at 16:12
  • 1
    Terminating appleeventsd works for me as well. It also fixes an issue where Archive Utility stops responding whenever you extract an archive.
    – Lri
    Jan 12 '13 at 9:51
  • 1
    I had to restart after following this step for it to take effect in 10.10
    – Drew C
    Jun 25 '15 at 15:34
7

I had to delete the lockfile also:

rm ~/Library/Preferences/com.apple.finder.plist
rm ~/Library/Preferences/com.apple.finder.plist.lockfile

and then restarting the finder (or you can reboot):

killall Finder
4
  • Didn't work for me. Nov 15 '12 at 20:52
  • Running sudo killall -KILL appleeventsd didn't work for me. Simply deleting my Finder preferences did, though. Jan 11 '13 at 13:54
  • Worked for me too! However, it undid the update to show hidden files that I'd done minutes earlier: mikesel.info/show-hidden-files-mac-os-x-10-7-lion Jul 23 '13 at 17:42
  • (But redoing that update to show hidden files didn't provoke the show in finder problem again. The first time I did the update it didn't "take", probably because the preferences file was already partly corrupted -- had to do the update twice.) Jul 23 '13 at 17:52
1

In Yosemite 10.10.2, this is what I did to fix it:

open a new Terminal window and run this command

defaults write com.apple.finder AppleShowAllFiles TRUE

Then restart Finder with

killall Finder

Open a new Finder window with right click Finder icon -> New Finder window (because the bug prevents the normal left click action), press Shift + Cmd + G (Go to) and paste

~/Library/Preferences

Delete

  • com.apple.finder.plist
  • com.apple.dock.plist
  • com.apple.systemuiserver.plist

Leave the Finder window open (I don´t know if it is necessary, but that´s what I did) Then switch to Terminal and paste

defaults write com.apple.finder AppleShowAllFiles FALSE

Restart Finder again

killall Finder

and finally

sudo killall -KILL appleeventsd

Restart your Mac, and chances are that everything is back to normal. Just remember that deleting the Finder preferences removes any custom views/side bar preferences, so just go through Finder -> Preferences again and fix things the way you like it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.