Here's my setup: On the second floor, I have my Rogers (Cisco) modem and my DIR-628 router. The network is set to WPA/WPA2 mode, running on channel 11, on 2.4GHz Band.

In the basement, I am trying to setup a VoIP router next to the demarcation point. The VoIP router issued to me by my provider is not wireless capable.

I purchased a DIR-505 and configured it as a repeater. The VoIP router's internet is coming via Ethernet connection to the DIR-505.

My problem: The phones are working just fine on VoIP. I've had no issues with calls so far. However, the presence of a wireless repeater appears to confuse/interfere with my laptop's WiFi. Randomly and the WiFi signal will drop and show the yellow exclamation icon on the network icon in Windows 7.

I called D-Link's people yesterday and it doesn't seem they can figure out why my laptop is randomly dropping the WiFi signal. It goes down for a few secs and then reconnects. I was assured that regardless my reason for setting up a repeater, my WiFi should not be dropping signal like this.

Does anyone have any suggestions as to how I can fix this? Worst case scenario, what device can I replace my DIR-505 with?

By the way here is the link for the DIR-505.

  • Is this WDS repeating or some kind of fake repeating using MAC rewriting or NAT? Also, are you using the same SSID on both sides of the repeater? And what firmware version do you have? – David Schwartz Sep 25 '12 at 23:54
  • I really do not know how to check. I know it's the same SSID though. I configured it using the set up wizard. I did however neglect the firmware though... I'll hafta look into that one. – Szuturon Sep 27 '12 at 2:18

Similar problem here. Also with DIR-505. OS is Win XP. Primarily Company laptop, which I use at home also in my own private network. Network is unsecured, i.e. I do not use passwords.

I tried assigning the IP address manually... and it seems that it fixed the problem.

I simply copied the information found from the IP configuration overview in the command prompt of Windows: START>RUN>type CMD>type IPCONFIG

...into the TCP/IP info box (In Windows "Wireless Network Connection">Change Advanced Settings> Scroll to find Internet Protocol TCP/IP> Properties

Hence I override the dynamically assigned IP address (which for some odd reason is a bizarroid ish non- number.

For DNS-server you will need to type in a randon DNS server. Just google for some.

cheers. Hope it helps.

btw.... they should sack the entire tech-support team at D-LINK. The guys there are truly and obviously incompetent as they are unable to find a solution to an issue which is MASSIVE for the DIR-505.


| improve this answer | |
  • I gave up on it and bought some TPLink PowerLine units. I wasn't aware of this product when I bought my DIR-505. The 505 is still sitting here... I guess I'll bring it along with when I travel and hope I find the opportunity to make use of it somehow :S – Szuturon May 15 '13 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.