28

I am using Windows 7. Problem is while using internet in Wireless if i connect LAN cable to my laptop, it stop Wireless connection and Wired Connection gets active.

I am using Internet using Wireless and doing my work through Wired Connection. I want to use Wireless and Wired Connections both at same time

HOW to use wireless and wired connection at the same time?

migrated from stackoverflow.com Sep 26 '12 at 6:42

This question came from our site for professional and enthusiast programmers.

  • 2
    I'd like to ask along with this, if they are being used at the same time would there be any significant increase in speed? I would assume only if the bandwidth at the router is larger that its LAN or WAN can provide; making the two connections each do "half the work"? – KDecker Sep 17 '14 at 1:22
26

The trick is to change the network card priority so that the wireless connection remains active when a wired connection is made.

The first step is to get to the "Control Panel > Network and Internet > Network and Sharing Center" page. On the left side of that page, click the link "Change adapter settings". This should bring you to the "Control Panel > Network and Internet > Network Connections >" page.

Select the wireless connection, right-click "Properties", and provide an admin password (if necessary). This should bring you to a dialog box named [wireless connect name] Properties".

In the list box titled "This connection uses the following items:", scroll down to "Internet Protocol Version 4 (TCP/IPv4)" and select it. The "Properties" command button will enable; click it. This should bring you to a dialog box named "Internet Protocol Version 4 (TCP/IPv4) Properties".

Click the "Advanced" command button. This should bring you to a dialog box named "Advanced TCP/IP Settings".

Near the bottom of the dialog box, there should be a check box named "Automatic metric". Uncheck it. That will enable a text box named "Interface metric". Fill in a number. It needs to be larger than 1 (reserved for loopback) and the number you choose for the wired network (see below).

Click three "OK" command buttons to return to the "Control Panel > Network and Internet > Network Connections >" page.

Repeat the above for the wired connection:

Select the wired connection, and right-click "Properties" to get to the [wired connection name] Properties" dialog box.

Select the IPv4 list entry and click "Properties", and on the next dialog box click "Advanced".

Again Uncheck "Automatic metric", and fill in a number in the "Interface metric" box. It needs to be larger than 1 but smaller than the number you chose above.

I would assume that it's also possible to give the wired network higher priority than the wireless, but I didn't test that.


Comment: Some other answers asked why one would want to do this. It's not for improved throughput; I doubt that Windows could effectively divide traffic between two networks like that. Instead, it's so that the machine can be connected to two distinct networks. In my case, the wireless network goes to my ISP, and the wired network goes to my Network-Attached Storage server.

Note: I found this general idea on a How-To Geek article titled "How to Change the Priority of Wired/Wireless Network Cards in Windows". The article has screen shots, but I've included a summary in case the link goes dead, and explained it somewhat differently.

  • Do I have to restart after this or anything crazy? – Brandon Oct 14 '16 at 14:18
  • I don't recall for sure. Way back when, just about any change in IP properties required a reboot, but I don't recall doing lots of reboots while I was trying to get this to work, so I don't think it's necessary any more. – Steve Oct 15 '16 at 6:06
  • Does not seem to work on Windows 10 Pro. I've set my WiFi and Ethernet's Interface metric to 10 and 3 respectively. – Barak Mar 21 '18 at 0:50
  • 1
    @Barak, I just looked at my Windows 10 settings, and I have "Automatic metric" checked. It works correctly; I didn't need to override the settings like I did with Windows 7. – Steve Mar 21 '18 at 7:07
  • I guess it has something to do with the Windows 10 version I guess? Because it also worked automatically with my colleagues Win10 laptop without modifying anything. – Barak Mar 23 '18 at 7:21
7

Chances are, your laptop's wireless card has a "disable on wired connect" feature configured as a default.

  • In Windows 7 Control Panel, launch Network and Sharing Center
  • Click "Change Adapter Settings"
  • Right-click the wireless adapter you're using
  • Left-click "Properties"
  • On the Networking tab of the Wireless Network Connection Properties window, click "Configure"
  • That will display the properties window of the wireless card.
  • Click the "Advanced" tab and see if there's an option for "Disable on wired connected" or similar language.
  • If there is, and it’s enabled, disable it.
  • 1
    This doesn't explain what to do if there is not a "Disable on wired connection" option, and is not entirely consistent with what happens on my system (Windows 7, SP1). I've created a new answer with more details. (I could have revised this answer, but if it's correct on other systems it would make it wrong for them.) – Steve Feb 27 '16 at 10:50
  • 1
    In my case it was "EnableAdaptivity" which was disabled and I changed it to Enable (also it has an "Auto" option which I don't know what it does). Anyway enabling that caused my wireless not being disable when a network cable is connected to ethernet port. – Ashkan Jun 5 '16 at 11:18
5

Some computers have a BIOS setting that determines this behavior. Whether this BIOS feature exists and where to find it is model-specific, but here are a couple of examples, which should at least help you figure out what to look for if you have a different model.

  • On HP laptops (probably all recent models, but I can vouch for EliteBook, ProBook, and ZBook systems), switch to the System Configuration tab, select Built-In Device Options, and uncheck the box next to LAN/WLAN Switching.

    enter image description here

  • On recent Dell laptops, go to SettingsPower ManagementWireless Radio Control, and in the right pane uncheck the box next to Control WLAN radio.

    enter image description here

AFAIK this BIOS feature doesn't exist on Lenovo laptops as of this writing.

1

Following up with a previous answer from @Steve, (i.e.: Network connections -> properties -> TCP/IPv4 properties -> advanced -> uncheck Automatic Metric, etc.) for my circumstances, setting the "Interface metric" the opposite way worked for me, i.e.: higher priority device = lower number.

Also as per a post from here.

0

This might be a little late, but yes you can do that, you need a Cisco router though...

Cisco routers are able to make two connections to one device, what you're looking for is either unequal cost path load balancing, or equal cost path load balancing. The router will transfer the data through both connections, if you want maximum speed you're best bet is getting a Cisco Gigabit router with wireless-N, or wireless-AC. Hope this help

  • 1
    This is only useful if you're trying to connect both the wired and the wireless network to the same things. Normally, one the reason to have more than one type of network would be for different types of traffic, such as an ISP and a backup server. – Steve Feb 27 '16 at 11:01
-1

you should bridge the connections.

  1. On the Windows 7, click on the Windows icon. Type view network connections and press Enter.
  2. Identify your Ethernet connection and your wireless connection. The Ethernet connection is called Local Area Connection and the wireless connection is called Wireless Network Connection.
  3. Click on Local Area Connection to select it.
  4. Press and hold the Ctrl key and click on Wireless Network Connection to select it. Now you should have both connections selected.
  5. Right click on the selection and select Bridge Connections.
  • I did same what u said but now i can only use Wireless connection but not Wired connection – user1379055 May 7 '12 at 8:25
  • Secondly i get IP from Wireless same as of previous – user1379055 May 7 '12 at 8:25
  • but now IP from Wired network changed :( and i cant access Network connection – user1379055 May 7 '12 at 8:26
  • I tried to create a bridge, and it appeared to work. I assume the machine on the Ethernet side could connect to the wireless network, but my Windows machine couldn't see either side of the bridge. – Steve Feb 27 '16 at 10:52
  • I used to do bridged connections all the time. Whoever gave this answer a -2 are morons. Running CPUID Hardware Monitor Pro it showed a downlong only happening on my gigabit connection. I right clicked my network icon, changed adapter settings, and created a Bridged Connection. It took a minute for both to show but I now have a network Bridge with both my wired and wireless. HMPro shows I'm getting 65 Mbps on my wired and 2.75 Mbps on my wireless simultaneously. – SASS_Shooter Mar 3 at 5:09
-3

There is no point to doing this since you will only be connecting twice to the same end router with the same WAN bandwidth. The fact you have 2 connections might increase redundancy but is pointless in a household environment.

Secondly, Windows does not know how to manage 2 connections simultaneously. For example, to establish a connection to a website you must perform a 3-way handshake before data is transferred using packets which contain the destinations mac address. Your router will send to the same interface which requested it because that's where the application layer (Windows) will expect the specific packet to arrive.

  • 4
    The point for me would be to allow me to access the internet via my portable hotspot from work using my laptop as per usual and to interface my laptop with my Raspberry Pi using a crossover cable. This because the portable hotspot has no network bridge function so I can't see the Pi's filesystem from my laptop. So no, I wouldn't "be connecting to the same router". – Roxysteve Jul 14 '16 at 21:38