I have an application that resides on a network share that all the users in my office use. They have shortcuts on their desktops pointing to this software and all is honky-dory. When you want to open the help file through the application itself (Help -> Help Topics) it opens a CHM file that resides on the share as well. The CHM file will not open and gives the typical error "Navigation to the webpage was canceled".

I have tried editing the registry using HHReg and allowing the max allowed zone to be all the way up to restricted sites without any luck. I have also specified the actual CHM files on the share as an allowed file without luck.

The CHM files open perfectly through explorer but will not open using this application which tells me that the problem is that the application is being run from the share, not locally. So there must be some other permission/security setting blocking the CHM file from being opened.

I have looked through all the information below without any luck:




Here is a related question but it isn't the same issue

  • I have this same problem with HP Quality Center / Application Lifecycle Management. The program gives us the option to directly download the CHM file from the application, and we are instructed to save it locally on the hard drive. Then it works. I think the workaround in your case is to set up an "install help file" script that launches when the user's profile is created, that copies the help file(s) from the shared drive to a known local folder, and creates desktop shortcuts to the files. Let us know if you find a way to open it from the shared drive without uninstalling the windows update. – allquixotic Sep 26 '12 at 14:32
  • That's too bad. I wonder if there's a way to replace the CHM file in the shared folder with a shortcut/symlink to the local copy (if I were to copy it down) so that when they try to launch it within the application it actually opens the one on their local machine. I'll play around some more. Thanks for the suggestion though! – qroberts Sep 26 '12 at 18:07
  • It's technically a flaw in the application (or rather, Microsoft made it a flaw) if it can't open its help from the shared drive. The only real way to get this resolved is to modify the app. – allquixotic Sep 26 '12 at 22:35
  • i installed AutoIT to a network drive and notice the same problem. Z:\AutoIT.chm works when launched from Explorer.exe, but not from the Z:\Scite\Scite.exe editing application. – rjt Jun 14 '14 at 2:09

We had the same issue with a 32 bit application on a 64 bit OS. Added the regkey(s) from article Microsoft kb 896054 to the Wow6432Node in the registry as well and it worked!!!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.