I have a very strange issue and I'm completely lost as to what it could be. I've worked tech support before, so I know that this is going to sound completely crazy.

I have a laptop that dual-boots Windows 7 and Fedora 17. When I am home and using the Windows partition on my laptop I am able to access all Google sites, but when I am using the Fedora partition I can't access any Google sites. No Gmail, no Docs, no Blogger, not even advertisements sponsored by Google on other websites load. Every other website loads fine. I've verified this happens in both Chrome and Firefox.

Here's where it gets weird. If I take the laptop to work and connect it to the network there everything works fine.

Here's where it gets even weirder:

  • I can ping google.com just fine, no packet loss.
  • I can telnet successfully to google.com port 80.
  • I ran 'wget -v http://google.com' and got a successful return.

My home ISP is Clear Internet (boo!) and their tech support has already dismissed the issue because they "do not support computers with multiple OS's" (which is BS because they couldn't list one single reason why that wouldn't work or why they don't support it).

Any help/ideas of any kind would be greatly appreciated!

  • 1
    Can you try on fedora with a different account? – Karthik T Sep 27 '12 at 7:34
  • I face same issue at my college, when I altered some proxy settings I don't know why, but I worked magically. (I understand that theoretically this does not sounds correct) – Ankit Sep 27 '12 at 13:37
  • @Lamb Were you only having a problem with Google (or another single domain) or was it with all websites? – jebar8 Sep 27 '12 at 14:15
  • it was just all google websites, exactly same as the problem. Other domains loaded perfectly. – Ankit Sep 27 '12 at 14:17
  • @Lamb do you remember what you changed? – jebar8 Sep 27 '12 at 14:26

If the same behaviour happen in browser safe mode then check

/etc/HOSTS, /etc/hosts.allow, /etc/hosts.deny files:

The HOSTS file must contain these lines (based on default Open Suse Linux):  localhost

::1        localhost ipv6-localhost ipv6-loopback

may be these ones:

fe00::0   ipv6-localnet

ff02::1   ipv6-allnodes

ff02::2   ipv6-allrouters

ff02::3   ipv6-allhosts

hosts.deny only this line:

http-rman : ALL EXCEPT LOCAL


By default : no lines except comments

| improve this answer | |
  • I will do this when I get a chance, but based on my understanding if it was a host file issue then it would be a problem when connected to other networks as well, right? – jebar8 Sep 27 '12 at 14:12
  • The HOSTS file may be used to block connections to specific Web sites (normally bad sites...). But if you have a line such as www.google.com in the HOSTS file no connection is possible with this Google site for example. That's why I ask you to verify if there's some unusual lines in the HOSTS... en.wikipedia.org/wiki/Hosts_%28file%29 or safer-networking.org/faq/hosts-file – climenole Sep 28 '12 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.