I want to set chrome to load HTTP instead of HTTPS for some websites. So I searched internet but all the solutions was old. They said go to Under the hood tab which doesn't exist in my chrome 22. Other parts, such as Security section also doesn't exist in my chrome.

Could everybody tell me how do I disable that? I prefer to be able to do it for some websites only. But any answer may help me.

  • 2
    Under the hood is now changed to Show Advanced settings – Sathyajith Bhat Sep 27 '12 at 8:30
  • Okay, next? Where to go? – Mostafa Farzan Sep 27 '12 at 19:11
  • 1
    Just curious: why do you want to do this? – Isaac Rabinovitch Mar 28 '13 at 3:03

The newest versions of Chrome come with HSTS (HTTP Strict Transport Security), and they also come with a preloaded list of sites that cannot be disabled from using the HTTPS protocol. Sites that you have added to HSTS yourself can be removed by going to about://net-internals/#hsts.

You could always make a proxy server that would convert HTTPS requests to HTTP requests. This would probably throw an error in the browser that it is loading over an insecure connection. Other than that, places like Google and Paypal will load with HTTPS.

  • 2
    "This would probably throw an error in the browser that it is loading over an insecure connection" You would have to install the certificate of your TLS proxy on your computer, as a trusted certificate. – curiousguy Jan 15 '14 at 2:15

Click on the lock icon just left to the address bar ( which shows that the site is using SSL) , click on the link 'show cookies and site data' , delete all cookies one by one by clicking on remove. This should fix the problem.

  • Cookies have nothing to do with this. – Brilliand Jun 23 '15 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.