I'm trying to setup a working CUDA SDK on my Linux Mint. I'm new to Linux and everything connected with it. So, I tried following some steps on how to install CUDA. Firstly, I downloaded a Linux driver from here: http://developer.nvidia.com/cuda/cuda-downloads version 295.41. After that, I barely found a way to run it.

I did it like this:

  1. typed in sudo init 1 in terminal and switched to root
  2. typed service mdm stop
  3. ran the *.run file downloaded from the link above

Then it started installing the driver. It gave some warning messages, but I ignored it. After installation, I typed init 5 and it came back to GUI screen, BUT everything is huge. I restarted, still huge. My screen resolution is 640x480 on a 17 inch laptop monitor.

I tried running Nvidia X server Settings, but it says: "You do not appear to be using Nvidia X Driver. Please edit your X configuration file." I tried that. Nothing happened. I cant change the resolution because that Nvidia Settings thing gives no options. Then I googled some things, installing some packages - nothing. The biggest problem is I don't understand whats really going on.

My laptop is a Samsung with i7 and Nvidia Gt 650M with optimus. I cant even install bumblebee, but that is something I will try if I manage to get my resolution to default. Please, help!

migrated from stackoverflow.com Sep 27 '12 at 13:58

This question came from our site for professional and enthusiast programmers.

  • This is off topic – keyser Sep 26 '12 at 12:25

Well. Go through the following three steps:

1) Try to reboot and boot into the system in run-level 1 initially and get the command line.

2) Run 'init 3'

3) Install the nvidia driver and admit the question about overwriting the xconfiguration file.

4) Reboot normally

Now you should have clean driver installation with normal screen.

  • Okay. So, what I did is I booted Mint, pressed ctrl+alt+f1 on the log in screen, logged in and then I typed "init 3" and then I tried to run the driver but it said: "It seems you are running X server." and exited. That is the problem. When I type in init 1, instalation goes through, but as I already said, everything is messed up. Thanks for you help. – darxsys Sep 26 '12 at 20:59
  • Does Mint have /etc/inittab (to change default run-level)? – ahmad Sep 26 '12 at 21:04
  • Nope. I tried googling that and there is nothing about changing run levels in Mint like that. There is no inittab file. :( – darxsys Sep 26 '12 at 21:14
  • Open new terminal (using Ctrl+Alt+F1) and then kill the X by 'service gdm stop'. Does it kill the X? – ahmad Sep 26 '12 at 21:20
  • It says unknown service. If you're thinking about killing the display manager, I can do it by typing service mdm stop, but then nothing happens. I mean, everything goes black and a white underscore keeps blinking at the top left of the screen and the only thing I can do then is press the power button and it shuts off. Doesn't react to any other typing or anything. – darxsys Sep 26 '12 at 21:26

I managed to install a working driver using this tutorial: http://eternalvoid.net/tutorials/linux-optimus-gt650m/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.