I have a brand new Das Keyboard Model S Professional that I just picked up the other day. I have it connected via USB - while I would like to use PS/2 for full n-key rollover, the media keys (and sleep key) doesn't work over PS/2 so I've reluctantly fallen back to USB for them to work.

However, after resuming from sleep, the keyboard doesn't work. It doesn't appear to be receiving power, and it doesn't appear at all under the Device Manager. (The USB hub on the keyboard does appear, however.) If I restart the computer or unplug the keyboard and plug it back in, it works again until the next time the system resumes. If I resume the system through some other method that doesn't involve the keyboard (e.g. clicking the mouse or pushing the power button on the case) the keyboard does work fine. This only seems to occur if I push a button on the keyboard to resume. It will appear to get power briefly (the num lock, caps lock and scroll lock lights do flash briefly) as the system resumes but it stops working after that.

I tested on a different Windows 7 system (my laptop) and I cannot reproduce this at all on that system.

I've tried the following:

  • Disabling USB selective suspend in the active power profile
  • Disabling "allow the computer to turn off this device to save power" for the USB Root Hub device the keyboard is connected to
  • Adding the registry DWORD value ForceHCResetOnResume for both the HID keyboard device and the USB Root Hub the keyboard is connected to
  • Negotiation tactics which may or may not have included anger, threats of destruction and tears

The keyboard is connected directly to an ASUS P8P67 Deluxe motherboard (Intel P67 chipset). The BIOS and chipset drivers are both updated to their most recent versions.

Any suggestions?

  • I have the same problem, although my keyboard wont come back even if I use the mouse to wake it up. – Joel Nov 10 '12 at 19:32
  • If you can connect via RDP from another computer, then RDP in, open Computer Manager, go into the Device Manager, and delete all entries for keyboard, then reboot it. They should show up normally afterwards. – Lizz Dec 14 '12 at 6:15
  • I tried deleting the keyboard via the Device Manager, no luck. Then I noticed that there was a PCI device in my computer which was acting up; (an old fax modem that had 6+ entries of itself in the device manager;) I physically removed the modem, and the problem with the keyboard now seems to have solved itself. – Mike Nakis Apr 30 '13 at 13:11
  • Is the device a dell?... used to see this a lot with dell laptops loosing usb devices when sleeping, and never finding them again until rebooted (no matter what we tried). – djsmiley2k Mar 19 '17 at 12:34

I have the same problem on Linux (Ubuntu). In fact, it has nothing to do with your OS or hardware. It's N-KEY Rollover's fault. Using it over USB involves some dirty trickery, and not working after resume is part of that.

In other words, the fault is in the keyboard, and probably the only way to solve it, is to not use it over USB (but then other things won't work...).

Some info regarding this: http://www.overclock.net/t/491752/official-mechanical-keyboard-guide

I recently discovered a workaround to get the keyboard working after resume, without having to unplug and replug it in: it is sufficient to just plug anything into its USB hub, and the keyboard should start working. At least in Ubuntu it works, not sure about Windows.

  • Links can die when content is moved or deleted and should not be relied upon as a fundamental part of your answer. You should quote the relevant parts and provide the link for attribution and reference. – Mokubai Jul 30 '16 at 9:04
  • Mokubai♦: Thanks for pointing that out. My answer is based on information from my head, gathered from reading various topics around the internet. The provided link is only for additional information, should the reader be interested in it. I do not quote it on purpose, as unfortunately it is not some credible manufacturer technical specification. – lenooh Jul 30 '16 at 10:21

A few things, I did not see if you mentioned using a USB 2.0 or 3.0 Port.

Your issues are very similar to ones I've encountered with some SteelSeries devices, the problem is that these devices are generally operating out of spec for low power mode, hence most of the work-around solutions involve disabling these features. I have found from personal experience that these devices also don't play well on a USB 3.0 port for whatever reason.

Based on your post above it looks like you've performed most of these steps, but I did not see you mention the Windows 7 Registry tweak of enabling DisableSelectiveSuspend. I would also suggest verifying that you have disabled these features on the correct USB Root Hub (especially if you have both USB 2.0 and 3.0 as these will be different controllers)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.