I've got a Lenovo Y580 with a 64GB SSD and a 1TB HDD setup using GPT and setup to boot from (U?)EFI.

I was trying to get my Linux Mint installation on the Windows boot manager using EasyBCD (I didn't realise EFI but it wiped my boot partition/loader and I cannot seem to get Windows back (and I still can't get a bootable Linux Mint).

Using the System Recovery utility, Startup Repair can't "see" windows (it might be because I'm using a 7 Pro disk to recover Home Premium?). In command prompt, Bootrec tools don't do anything and bootsect can't run because it says that it's for BIOS only and I've booted with EFI.

I can see the EFI data on the 200mb SSD partition using diskpart but I don't know how to add Windows back onto whatever bootloader I have/need.

At the moment the only options I can see are:

  1. Do a fresh install of Windows and hope that the setup remains as fast as the default one (the SSD is some kind of cache for Windows but I can't quite see how it works given that the rest of the SSD is unpartitioned space). This seems like overkill given that Windows was working fine til EasyBCD deleted it.
  2. Try forcing BIOS mode and see if that somehow magically fixes things
  3. Try converting from GPT to MBR to try and use the bootrec/bootsect tools (and maybe back again) which seems like a really bad idea.

Anyone have any ideas?


Check your firmware settings for booting Windows recovery/installation media.

You should set options in firmware to boot recovery/installation DVD/USB the EFI way.

After booting recovery media go to command prompt.

Use bcdboot.exe to repair Windows Boot Configuration Data (BCD).

  • Thanks. I suspect this would have been the answer had things not got worse, forcing me to do a full reinstall. – drent Oct 3 '12 at 12:22

Boot from another disk or live CD and try to see if the partition is still OK (with tools such as easeus or diskpart), primary and active. Then you can use:

bootrec /fixmbr
bootrec /RebuildBcd

Or, try again with easybcd and a different option from the live CD.

Also make sure that you set the proper options in the BIOS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.