When a known USB 2.0 device is plugged in and detected, it doesn't install the driver correctly but shows a Code 28 error and lists the device under "Other Devices" in Device Manager. When view properties of this device , it shows the following status;

The drivers for this device are not installed. (Code 28)

There is no driver selected for the device information set or element.

To find a driver for this device, click Update Driver.

When updating the driver manually and selecting the appropriate driver Windows doesn't believes it's the correct driver, but you can force the installation and it works!

The other condition the driver will auto-install is when the same USB device is plugged into a USB 3.0 port. Power related issues are not also causing this as I have tried vi a Docking station, USB hub. etc..

Devices tried;

  • Jabra Headset
  • USB-Mass Storage Device (flash disk and ext HD)
  • MS Wireless Keyboard & Mouse
  • USB Ethernet controller (USB-MAC controller)

This is on a laptop part of a Domain with Windows 7 Ent 7601, I am logged in as a local administrator. There isn't any Group Policies blocking not signed driver or whitelisted devices on the domain.

Any suggestions please feel free

  • Can you post what the device(s) are that you are plugging in. – user88311 Oct 1 '12 at 14:05
  • @user88311 ok added list of devices tried, – Darragh Oct 1 '12 at 14:39
  • @BroScience I tried what you suggested, but the Root Hubs reinstalled but known of the devices nested devices – Darragh Oct 1 '12 at 20:15

I was also having this problem, and found the solution here:


The gist of it is that usb.inf (which should normally be in C:\Windows\inf) was missing. Copying it from another computer fixed it.


You can try 2 things

  • Go to device manager and uninstall all of the USB Root Hubs. Reboot and they will reinstall automatically. After that, try and in plug something in it should be ok. If that doesnt work;

  • Go To Hkey_Local_Machine\system\setup Look for 2 keys and set them to 0, then restart

    1. SystemSetupInProgress -0
    2. FactoryPreInstallinProgres -0
  • I was able to fix this problem by uninstalling the USB Root Hubs (without checking the Uninstall driver checkbox) as mentioned above, but after restarting, they did not automatically reinstall, even after using "Scan for hardware changes" in Device Manager. I had to then download and rerun the installer for the Intel USB 3.0 Driver before the hubs and devices would appear and reinstall again, which required RDC since my mouse and keyboard use USB. After that, my new USB 2.0 Hub [MTT] and its children were automatically recognized. – Aldaviva Jun 20 '19 at 6:51

I solved the problem as below:

  1. replace the usb.inf and other relevant file in (C:\Windows\inf)
    [ you could download the file from the link here http://www.filedropper.com/usbinf ]

  2. restart your pc (please remember to Uninstall your device under Device Manager before restarting it)

  3. plug in your device (let's the device setup completed), under Device Manager choose Update Driver Software...

  4. you should be able to see your device in File Explorer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.