I see some info on the net that suggest that I should be able to get my USB 2.0 devices to work in 3.0 ports. I only have two 2.0 ports on my new computer, and six 3.0 ports. I have installed drives. There's two different drivers, I guess some of the ports are supported by the intel board and some supported by some other chipset on the motherboard.

I however have yet to get any of the 3.0 ports to work, and my brother had had the same issue with his devices not working in 3.0 ports on his computer. So I am beginning to wonder if the backwards compatibility isn't reliable for some reason. Maybe manufacturers opting not to implement 2.0 support on the 3.0 ports. I understand that physically the wiring is there, but that is only half the story.

Beyond my brother's and my own computers (different motherboards/everything), I have yet to see a 2.0 device work in a 3.0 port. Is there any reason for this apparent device incompatibility? I.e. looking for responses that would indicate what areas to explore for issues or if there is any known cases of manufacturers deviating from spec in hardware or drivers. I am aware it's "supposed" to work :)

Update: Does this have any relation to "USB Legacy Support" options in the BIOS? There several options combinations of options with "USB Legacy Support" and "USB 3.0 Legacy Support" and the description for these is a bit confusing, sounds like a bad translation.

  • 1
    I've certainly used a USB2 memory stick in a USB3 port .. it was one test case I conducted when I installed a USB3 card in my PC. I don't have any other evidence for/against general compatibility, though. – Chris W. Rea Oct 2 '12 at 2:02
  • Have used multiple USB 2.0 devices on 3.0 ports without issue. The specification clearly says the 3.0 standard is backward compatible – Dave M Oct 2 '12 at 2:14

From Wikipedia:

Compatibility of USB 3.0 connectors

  • Type A plugs and receptacles from both USB 3.0 and USB 2.0 are designed to interoperate.
  • Type B receptacles in USB 3.0 are somewhat larger than would be required for a Type B plug in USB 2.0 and earlier. This is intended to allow connecting an older Type B plug into a newer USB 3.0 Type B receptacle. Accordingly, a USB 3.0 Type B receptacle on a peripheral device can be connected using the corresponding plug end of a USB 2.0 Type B cable.
  • Type B plugs in USB 3.0 are somewhat larger; therefore, a USB 3.0 Type B plug cannot enter a USB 2.0 or earlier Type B receptacle. Accordingly, normal USB 3.0 Type B plugs cannot be inserted into normal USB 2.0 Type B receptacles found on peripheral devices (and connect them to a computer).
  • A receptacle for eSATAp (eSATA/USB Combo) is designed to accept USB Type A plugs from USB 2.0 and USB 3.0.

In theory, there should not be a problem at the hardware level. However, there may be a problem with the drivers or the underlying controller for the ports.

To determine if this is a hardware or software problem, try booting into a Linux live CD and see if USB 2.0 devices work in the USB 3.0 ports. If they do work, the problem is in the drivers. If not, the problem is in the hardware.

Legacy support in the BIOS only applies to systems that do not natively support USB in general. When this setting is enabled, the BIOS attempts to provide a compatibility layer for very old operating systems such as Windows 95 or MS-DOS, so that storage devices attached to these ports can be used (probably with some restrictions such as no hot-plugging). I'm not sure about this, but USB 3.0 legacy support setting is probably to allow USB 3.0 devices on such operating systems to communicate at USB 3.0 speeds. An operating system that supports USB should not be affected by these settings, as they can communicate with the USB hub controllers directly without having to rely on the BIOS.

| improve this answer | |

I've tried plugging in USB 2.0 devices such as flash drives, external HDDs, keyboards, mice, etc into USB 3.0 ports on the HP ENVY 15 and the Macbook Pro Retina without any issues.

If you guys built the computer yourselves, make sure you have the latest drivers installed.

P.S. I am aware of some people having issues with USB 3.0 compatibility on some very early USB 3.0 capable hardware that rolled out about 2 years ago.

| improve this answer | |
  • I think it is a driver issue, but I have uninstalled/reinstalled/rebooted. The devices work fine in the BIOS, but not in the OS. So physically the connection and hardware works since it works in BIOS. Doing some reading it sounds like the drivers are not always implemented correctly. – AaronLS Oct 2 '12 at 2:39

I put BIOS settings back to original values, gave up on hunting for newer drivers, and decided to focus on Device Manager.

In my case I could see under Device Manager(go to Control Panel and enter Device Manager in the upper right search field) a couple "Unknown device" entries under the Other node. Right click->Properties->Details->Hardware Ids, I Googled each. One was Intel Smart Connect which I deliberately didn't install and unrelated to USB so I ignored it and moved on to the other Unknown device. The other had "USB" as part of the hardware ID(but not all will be this obvious), but you can right click one of them from the Values section and clicked Copy then google it, and there are some driver sites out there that will have that ID and give you a clue as to what it is. In my case it was a "Intel(R) USB 3.0 Root Hub". This is the screen:

enter image description here

This screen was after fixing it, while it is Unknown it won't have the name or icon up top, but you can still copy the hardware IDs for Googling.

I strongly distrust the driver sites as some might have malware/adware. I would only download drivers from Microsoft or the manufacturers.

In my case, I had already exhausted the Intel USB drivers with several installs/updates/reboots with no luck.

Having found the specific device that was having problems though, I went to the Driver tab and chose Update Drive...

enter image description here

And then chose "Search automatically...". To my surprise it found the driver and installed it. Give device manager some time to refresh. There was then another entry in the Other Devices node, as if once it had the first device working it could then see a "USB Root Hub", I opened it and did Update Drives->Search as well. It seemed like the 3.0 Hub was fixed, then the system could see the other hub which I assume is the 2.0 Hub.

After installing the drivers for both of these via the search online feature, I could then plug in a 2.0 device to a 3.0 port, and get a Installing device notification, and shortly it would be working.

I can't remember the "Search online" for drivers feature ever working before. I doubted it would work also because I had already run Windows Update, and at some point in the past Windows Update used to download drivers in the optional section(which is worth a try for others having similar issues).

By the time I was done, I had entries for the USB 3.0 Host Controller, USB 3.0 Root Hub, and USB Root Hub.

| improve this answer | |

Some motherboards support 3.0 using more than one chipset. In my case the front and 2 of the back USB 3.0 ports were Intel ports, 2 were Intel 2.0 ports, and 2 other 3.0 ports were supported by ASMedia ASM1042 drivers.

So I needed to try each port to determine which back ports were not working and which were. It was important to leave the device plugged in for at least 10 seconds or so to give Windows time to start installing drivers and then wait for the notification to indicate it was successful. Once I knew which ports were working, I then uninstall both ASMedia and Intel drivers, rebooted, installed only the ASMedia drivers, and the ports started working, indicating that the ASMedia ports+drivers worked(although a reboot might be required, it wasn't for me). So now I know the others not working are Intel ports.

Then I could plug my device into the other non-working ports and be certain of which ports were and were not working and which drivers went with the non-working ports, so I could focus on that and not keep wondering which driver was the problem.

Also I focused on the back ports because if there was a connection issue with the front ports, then I wanted to not let that prevent me from determining when/if the drivers were installed correctly. (When you have more than one thing wrong it is difficult to fix because you fix one thing but don't know it's fixed cause something else is also wrong, so you undo your fix thinking it wasn't really a fix.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.