I have a Western Digital My Passport 2.0 TB and I think I may have had a bad ejection one time when I ejected my hard drive. When I try to plug it in on my ubuntu 12.04 machine, it gives me this error:

Error mounting volume
An error occured while performing an operation on "My Passport" (Partition 1 of WD My Passport 0748): The operation failed

Error mounting: mount exited with exit code 13: $MFTMirr does not match $MFT (record 0).

I tried to run ntfsfix /dev/sdd but it didn't work it said

Mounting volume... NTFS signature is missing.
Attempting to correct errors... NTFS signature is missing.
Failed to startup volume: Invalid argument
NTFS signature is missing.
Trying the alternate boot sector
Unrecoverable error
Volume is corrupt. You should run chkdsk.

But the thing is, I plugged it into my friend's Macbook and it worked fine...


Mohammad's answer should more or less fix your problem, although I will note if it persists or worsens, it could be MBR or partition table problem, in which you could use software like Gparted to check to see if it is, and or possibly fix the problem.


Usually when a computer is switched off either in the middle of startup or shutdown, it doesn't mount NTFS drives in Ubuntu. Going back to Windows and running chkdsk /f (example chkdsk e: /f) solves all the problems. Since you don't have windows anymore, you need to install ntfs tools in Ubuntu:

$ sudo apt-get install ntfsprogs

This package has a nice collection of tool for ntfs drives. To fix your problem let's say your drive is /dev/sda2

$ sudo ntfsfix /dev/sda2

This should fix the disk. Reboot after this.

I shall add, make sure your extension is the right one (you can find this on the original error message you got).

If it still doesn't work use a Live CD like Hiren's Boot CD mainly for DOS or there are a lot of others (here is a List of rescue n repair live CDs). Try the one you like. Hiren's Boot CD has chkdsk utility. System Rescue CD is another nice rescue CD.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.