7

I have a tmux session with several windows. One of those windows is running irssi. I spend most of my time connected to one server and in one channel, so I'm not really changing windows inside irssi.

I've turned on the "bell_beeps" setting, and I've set "beep_msg_level" to all. "beep_when_window_active" is turned off because I don't want it beeping when I'm using the tmux window containing irssi and having conversations. When I want to switch to another tmux window, I do so without changing irssi windows.

The problem is that irssi doesn't know I've changed windows in tmux, so it still assumes the channel I'm in is "active" and therefore doesn't beep when I get a message. Is there anyway I can get it to beep when I'm in a different window, but this channel is still the irssi "active" window?

2 Answers 2

3

I believe this setting is what you're looking for:

/set beep_when_window_active on
/save
0

What Artem Ice is saying is coorect. Also, on some terminal you have to turn on beeps in the terminal as well as they are sometimes (by default) turned off in the configuration settings of the terminal you are using.

Cheers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .