65

I have a Spanish keyboard on my notebook, but I use it mostly for English and Chinese writing.

This is how I configured the languages:

Language preferences

However, Windows added some layouts on its own (probably when connecting via Remote Desktop to computers with different languages/layouts):

Available layouts

Those layouts are all part of the AltShift cycle, which is extremely annoying.

How can I remove ENG/US and ESP, considering they don't show in the configuration list?

Is there a way to prevent them from being added again?

71

I was able to remove the unwanted layouts by creating an IgnoreRemoteKeyboardLayout DWORD in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout and setting it to 1

Credit goes to this post.

  • 2
    You are a savior.. RDC from Mac Automatically sets US English, Even tho I used Dvorak on both Mac and Windows. – The Lazy Coder Aug 2 '14 at 0:44
  • 1
    Could you please provide detailed instructions how exactly do you add "IgnoreRemoteKeyboardLayout"? I reach the point when I am in the above mentioned registry path and right click "New", but I do not know what to select afterwards. I also see this "QWORD (64 bit value) - should I use this instead of DWORD? – drabsv Aug 17 '16 at 6:30
  • Could you give a step-by-step instruction how this could be done in Windows 10? Thank you! – Richard Hardy Sep 14 '16 at 14:58
  • 2
    Worked perfectly for me. The US keyboard layout was being automatically added for every RDP session. This registry setting stopped it. Thanks!!! – Jez Jan 29 '17 at 13:41
  • "drabsv" 17 Aug 2016 06:30, "Richard Hardy" 14 Sep 2016 14:58, Here's how: Start, Run, RegEdit, HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout In right pane, right-click and choose "New" then "DWORD Value", name it "IgnoreRemoteKeyboardLayout" Double-click the name you just wrote (or right-click it and choose "Modify") then under "Value data" type "1" (don't mind "Hexadecimal" or "Decimal", both will do) Versailles, Thu 29 Jun 2017 10:19:50 +0200 – Michel Merlin Jun 29 '17 at 8:19
11

Add the offending languages under language in control panel, then delete them and they will be gone from the notification area.

  • 13
    There is however an issue when sometimes EN/US will be added back (not sure how/why), I think Diego's self-answer does the trick. – Goodwine May 26 '14 at 15:28
  • This worked for me when the US english keyboard suddenly appeared out of the blue in my language bar. – PAK-9 Sep 18 '14 at 14:27
  • 1
    Yes they keyboard is re-added at any moment later. There is no way to permanently delete it. – andreszs Aug 28 '15 at 14:38
9

The keyboard layout (in Windows 7 at least) is contained in the registry key HKEY_USERS\.DEFAULT\Keyboard Layout\Preload.

Preload determines which keyboard layouts are present in the keyboard switch button (on the bottom right of the taskbar), and the number determines the ordering. The REG_SZ item "1" contains the first layout, "2" the second, etc.

The article Windows Keyboard Layout lists most keyboards ids. You would also find your above layout ids defined as sub-keys of the registry key :
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\keyboard layouts.

It would be interesting to know what your registry contains at these locations.

1

For me, currently (2018) there is no solution. There's a bug since windows 7 that Microsoft is not handling, by which a default keyboard is added, usually English US, English International or in my case English UK, and cannot be removed. But here are the options you have and can try, with various versions of Windows 10, which did work for others. Hopefully, your case is different from mine.

You can get to the languages settings panel in the following ways:

  • Control panel / (some versions) Clock Language and Region / Language
  • Control panel / (other versions) search for 'region' / choose Region ... click the underlined link 'Language preferences' (not noticed at first, it's under the first combo-box where you choose the "Format" country)
  • Click on the language indicator in your tray and choose Language Preferences
  • Start / Settings (Write "settings" or choose the Settings icon - a cog icon) / Language preferences

Now there are several possibilities:

  • If the language you want to remove is missing, add it, reboot and remove it.
  • If the language you want to remove is listed, choose it, and a Remove button will appear. Remove it and you are all good. But then...
  • If the Remove button is gray, you can try the following (which worked for some older versions of Windows 10 and now does not. For me the language and regedit key just pop up again)

Regedit and remove the keyboard not needed from: Computer\HKEY_USERS.DEFAULT\Keyboard Layout\Preload

Then log out and back in.

00000101    Arabic
00000402    Bulgarian
0000041a    Croatian
00000405    Czech
00000406    Danish
00000413    Dutch (Standard)
00000813    Dutch (Belgian)
00000c09    English (Australian)
00001009    English (Canadian)
00001809    English (Irish)
00001409    English (New Zealand)
00000809    English (United Kingdom)
00000409    English (United States)
0000040b    Finnish
0000040c    French (Standard)
0000080c    French (Belgian)
0000100c    French (Swiss)
00000c0c    French (Canadian)
00000407    German (Standard)
00000807    German (Swiss)
00000c07    German (Austrian)
00000408    Greek
0000040d    Hebrew
0000040e    Hungarian
0000040f    Icelandic
00001809    Irish (English)
00000410    Italian (Standard)
00000810    Italian (Swiss)
00000414    Norwegian (Bokmal)
00000814    Norwegian (Nynorsk)
00000415    Polish
00000816    Portuguese (Standard)
00000416    Portuguese (Brazilian)
00000418    Romanian
00000419    Russian
0000041b    Slovak
00000424    Slovenian
0000080a    Spanish (Mexican)
0000040a    Spanish (Traditional Sort)
00000c0a    Spanish (Modern Sort)
0000041d    Swedish
0000041f    Turkish

Someone wrote that choosing the Administrative tab on the "Regions settings" window (you can re-open it from the Region & Language settings by clicking on the "Administrative language settings" on the right under "Related settings") and then Copy settings, set both checkboxes to checked and ok. But I don't see how this can help. It didn't for me.

If like me it didn't help, I was able however to change the ORDER of languages so that the first language was mine (Hebrew) the second the desired second keyboard (English US) and the third - the undesired one (English UK) so that when changing via the keyboard (Windows + space, or left-Alt + left-Shift) going from Heb to English I reach the desired kb, and going from English to Hebrew I see it didn't change so give it another extra change to reach it. (This helps me with the missing indication due to having ENG written for both the US and UK keyboards. I opened a separate bug for this on the Microsoft discussions website)

I also found some info about changing the keyboard "system permissions" which I will not repeat because it may be the cause for these solutions to not work.

  • That didn't work. It just came back up after the reboot! – pashute May 23 '18 at 11:11
  • In your reply of 23 May 2018 you don't mention Diego's self reply of 07 oct 2012 15:14:30 GMT (creating an IgnoreRemoteKeyboardLayout DWORD in "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout" and setting it to 1); have you tried it? It should make the problem go away and never come back even after restart Versailles, Tue 14 Jan 2020 23:30:20 +0100 – Michel Merlin Jan 14 at 22:30
-1

On Windows 10, you can remove keyboard inputs / layouts here:

  • Control Panel → Clock, Language, and Region → Language → Language options

If you have multiple display languages installed (let's say "English" & "German", then you need to check your keyboard inputs for each language).

Screenshot:

enter image description here

  • 2
    this addresses the regualar way of adding/removing keyboards in windows - the asker states that they arent listed there – BobbyTables Feb 22 '18 at 17:29

Not the answer you're looking for? Browse other questions tagged or ask your own question.