I have no sound on my computer

The speaker icon has a red x on it and it says: No audio output device is installed.

I have done everything step by step following the Window Help and support, Compaq and many other troubleshooting sites that I found online.

I used system restore three times and that didn't work.

I updated everything in the list below:

  • Realtek High Definition Audio Driver
  • Realtek RTL8139/810x Family Fast Ethernet NIC
  • NVIDIA GeForce 210
  • Network Adapters
  • 4 different NVIDIA High Definition Audio Drivers
  • ATI/O Communications Processor SMBusController

When that didn't work...

I manually downloaded and installed each driver again. When that didn't work

I uninstalled and re-installed them again when that didn't work

I used each of the programs below to troubleshoot and auto fix the problem.

  • Windows
  • SlimDrivers
  • Microsoft Fix it

Still no sound and the same message over the speaker icon on the task bar.

Below is all the information about my computer

Compaq Presario SR1710NX
Windows 7 Ultimate
Service pack 1
Processor: AMD Sempron(tm) Processor 3400+2.00 GHz
RAM 4.00GB (2.75 GB usable
32-bit Operating System
  • Has it ever worked or was it this way from install/purchase? It sounds like a bad soundcard honestly. Do you see the soundcard in the device manager? – MaQleod Oct 4 '12 at 0:17
  • It is about 3 years old and worked fine until about 2 weeks ago. – user162955 Oct 4 '12 at 0:28
  • Definitely check the device manager, your soundcard might have failed. Might even be worth opening up the box and reseating it. – MaQleod Oct 4 '12 at 0:32
  • Yes I did find the sound card in the device manager. A storm had knocked our power out the night before so forced it to shut down. – user162955 Oct 4 '12 at 0:37
  • I did open the box already and do that too – user162955 Oct 4 '12 at 0:38

I've had exactly the same problem with roughly the same hardware.

When re-installing drivers, checking settings etc produced no change the motherboard's manufacturer's hot line service (ASUS) said that a hardware fault was indicated and asked me to send it in for replacement. To speed up things, I bought a new identical motherboard and installed it. No change - the problem persisted so it is NOT a H/W problem!

As I have both 64- and 32-bit W7 installed I took a chance and booted the system to run under 32 -bit W7, instead of 64-bit. AND THE PROBLEM DISAPPEARED! So it is not a BIOS problem either, but apparently something has happened with my W7 64-bit installation.

Next I'll try for a system restore or see if I can repair W7/64 without having to re-install it from zero.


Try run, services.msc, find Windows Audio, and click restart

  • Tried that already and it didn't help – user162955 Oct 4 '12 at 0:14
  • I will try it again and let you know if there is any change, Thank you – user162955 Oct 4 '12 at 0:16
  • I tryed it again, rebooted and still no sound – user162955 Oct 4 '12 at 0:24

If you go into the sound icon in control panel, on the playback tab check that the output device is still the realtek sound card and it hasn't switched to the nVidia HDMI.

If this is correct make sure your speakers are plugged into the correct socket or test with a set of headphones. I know it sounds stupid but it's best to check.

  • it says no audio device is installed – user162955 Oct 4 '12 at 21:23
  • I know the NVIDIA GeForce 210 was installed new out of the box about 3 years ago. So should both be showing in the device manager? Because they do. – user162955 Oct 4 '12 at 22:21
  • And I have been using a head set also – user162955 Oct 4 '12 at 22:25
  • Could you check if it's a hardware issue by booting from an ubuntu live CD? – Col Oct 5 '12 at 8:26

Follow these steps:

Right click on my computer -> click on device manager -> Right click on sound and video game controller -> then click on update driver software

If you have driver software in your PC, browse to it from here. Otherwise, the system will look for the proper drivers on the internet, requiring an internet connection.

  • when I right click on sound and video game controller is gives the option to scan for hardware changes or open properties which when opened just shows "sound and video game controller". But when I left click sound and video game controller, it shows 4 NVIDIA HIGH DEFINITION AUDIO. I have up dated each of them and uninstalled and re installed them also – user162955 Oct 4 '12 at 22:42

This always happens after I've been 'offered' a flashplayer upgrade and I've clicked on 'later'. Best thing is to go to


... seems to work for me. Then I usually re-start.


I had the same problem, try these options-

1. go to command prompt and run it as an administrator, then type sf /scannow, that should check for windows related problems and can solve them. Just remember to restart computer after to apply fixes.

2. This is the bad news, you will have to reinstall windows and shold bring everything to default, you will loose all your data but you can back-up picture, files, documents, videos.


On a Compaq Presario F700, Vista 32-bit I tried to no avail most of the things proposed here and elsewhere (updating drivers, BIOS, etc.).

I came across some advice to put the laptop into hibernate mode and then turn it on again.

As a last resort, did just that, additionally removing the battery and then inserting it back. And it helped!

Sound is back - physically and virtually (reappeared in Device Manager and other services).


Installing a new video card can disable the on-board sound chip so check the following.

Shut down the PC. Tap away at f10 as soon as you press the power button to access the Bios Menu - the option you want is most likely under the Advanced Tab. Look for an entry titled 'Onboard Audio'. If it shows as Disabled, navigate to it using the arrow keys, hit enter, use the arrow keys to select 'Enabled' and hit enter again. Press f10, select 'Yes' or 'Ok' and hit enter to save the change.

Some PCs may not be f10 for the setup try to look for it.

protected by Community Jun 25 '14 at 3:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.