18

In Windows 7, I use the "Auto-hide the task bar" feature. Usually, it works fine: As soon as the pointer touches the screen bottom, the task bar pops up.

However sometimes, it refuses to rise. Pressing the "Windows" key (or Ctrl-ESC) makes the start menu appear, forcing the task bar from hinding as well. Once I've done this, the task-bar auto-rises again. This is annoying, it interrupts flow. Has anyone else noticed this? How do I avoid this?

Searching for "Windows 7 task bar auto-raise" shows that at least one other person experienced this problem: How can I fix the taskbar's auto-hide?(Microsoft Community Post)

To answer the question posed by the "helpful" support engineer on the above page, of course I am running some apps when this happens, usually Windows Task Manager (minimized to notification area), Windows Explorer, Firefox, Eclipse, Cygwin/X, Xterm, Cygwin Emacs, gitk, git gui, Notes, a chat client, a VPN client, a Firewall.

If my memory serves correctly, I have seen this behavior on earlier versions of Windows as well, XP at least, but not nearly as often as currently on Windows 7.

So far, it appears to happen out of the blue, sometimes multiple times a day.

I am unable to directly reproduce this behavior so far. To reproduce this behavior, I tried switching between apps, and bringing apps to open other windows.

See my comments below for some more info.

Looks like a bug to me. The task bar should raise no matter what.

Edit:

I normally use the "Classic" Windows style, with all animations disabled. I switched to "candy" (Aero) style to see if that helps, but the issue still occurred.

I'm pretty sure I've seen this behavior when I was not using Eclipse, but Eclipse is definitely the program that most often triggers this behavior.

As reported by Malachi, there is a record on Eclipse Bugs that also tracks this issue. It has been opened in 2002-09. Wow, more than ten years ago. However, users on another page found by Malachi have reported that other programs, for example Firefox can cause this behavior, too, so this is not an issue exclusively caused by Eclipse.

The issue could be caused by Eclipse, or Windows, or the JRE. If the issue is a Windows or JRE limitation, I still say Eclipse should stay clear of it. Other programs manage to do that as well.

My current theory is this: Normally, there is exactly one row of pixels of the task bar visible, and in front of all other apps, even when an app is maximized. Since the task bar is in front (at the top of the Z order), it "sees" the pointer when the pointer hovers over it. When the issue occurs, the task bar is no longer in front of every other app, so it does not receive "hover" events. Only where no other window occludes it does it still receive hover events.

If the task bar needs to be on top with at least one row of pixels visible, it is Windows' responsibility to ensure that this is the case. The OS is the master and must not let applications dominate the GUI interaction. There are exceptions, such as movie players, where you do not want a light line of pixels being visible (just color it black!), or where the task bar should not rise at all, such as in full-screen games. In my view, Eclipse or a browser do not require an exception.

Here's a description of a typical incident:

Eclipse was in front. I moved the pointer to screen bottom, the task bar would not rise. When Eclipse was not maximized, leaving a little space on the right, I was able to make the task bar rise behind the eclipse window, by "touching" the bottom right corner. Moving away, the task bar hid again. This worked repeatedly. When I touched the center bottom, the task bar did not rise, not even behind Eclipse. Next I maximized the Eclipse window. The task bar could not be raised. Restored the Eclipse window -> Same as before the maximize-restore cycle (rose only when bottom right was touched). Then I alt-tabbed to Firefox, which was maximized at the time. Still no task bar. In the non-maximized state with Firefox it was as with Eclipse. Same for other apps, for example Notes. Next I alt-tabbed to Emacs, its Ediff control window, to be precise. And suddenly the task bar worked again. The Ediff control window was not maximized, and did not touch screen bottom (it is usually never maximized). The Ediff window can not be the culprit, as the issue mostly occurs when I have no Ediff window open, and it was sitting there all day and the task bar was working.

So when this happens, it "applies" to more than one app. At least Eclipse and Firefox are "stronger" than the task bar. In one instance, Eclipse was on top, gitk at the bottom, and the task bar in between.

Maybe there is a program that allows inspection of the Z order, or logs changes in the Z order?

12
  • 1
    Do any of your apps have an option to set "Always on Top"?
    – kmote
    Commented Oct 4, 2012 at 18:33
  • The only app that has this set is Windows Task Manager ("WTM"), but that is usually minimized to the notification area. Even when WTM is visible (and forcedly on top of any other windows), the task bar normally rises properly. I experimented briefly: When WTM is maximized, it appears as if the task bar fails to rise. However, when I resize WTM so that it stretches to the bottom, but not to the sides, I see that the task bar does indeed rise, but behind WTM. So... maybe some app temporarily sets itself to "Always on top", like a modal dialog, maybe because it wants to notify me of something. Commented Oct 5, 2012 at 8:02
  • 2
    Since it's not repeatable it may be tough to find it, but I would advise that the next time it happens you systematically shut down applications to see if you can detect a culprit. You might also consider stretching your taskbar across both screens for a while, to see if it appears on the 2nd while being blocked on the first
    – kmote
    Commented Oct 5, 2012 at 15:13
  • 1
    Ahh, you're right -- my mistake. I slipped into the old WinXP mindset there for a minute. Sorry.
    – kmote
    Commented Oct 5, 2012 at 18:03
  • 1
    No solution yet. People who can read already know it's that bug. Btw., I can't see any evidence of it "being looked at". Your reply is the best so far, so I upvoted it. Since it does not answer "how to fix" I'll leave accepting for a true fix or workaround. Commented Nov 9, 2012 at 9:30

11 Answers 11

4

This drove me crazy, so I decided to dig really deep to the bottom of this problem and swore to get to the root cause no matter what. I went as far as reverse engineering Windows binaries.

What I found was a particularly subtle Windows bug where, under very specific conditions, Windows mistakenly thinks you are using a full screen application (even though you're not) and hides the taskbar as a result. The bug involves a race condition which is non-deterministic in nature, which is why it can be quite difficult to reproduce.

I was able to reproduce, characterize, and root cause the problem, and I also came up with a workaround: RudeWindowFixer. You will find all the gory technical details there.

In particular, if you were disabling the GeForce Experience overlay, then I'm pleased to inform you that with RudeWindowFixer you can keep it enabled and still get rid of the issue.

While the workaround reliably gets rid of this particular bug, I would not be surprised if there were similar Windows bugs in related code paths that require separate fixes, so I wouldn't necessarily claim it will 100% get rid of the problem. If you experience this issue even with RudeWindowFixer in place, do let me know and we can try figuring it out together. For better or for worse I have become exceedingly efficient at investigating these code paths…

I also filed a Windows feedback report about this, which I would encourage you to upvote to get Microsoft's attention!

1
  • 1
    Cloned that repo immediately. :-D Thank you for this analysis. I hope it has been fun for you to track this down. Not a Windows user atm, so can't try this out (or even just use the Windows feedback channel you mentioned) in short term. Excellent write-up in the repo README. As far as I can see, this could explain the typical incident I described. Invisible fullscreen windows, the security implications give me goosebumps. Just say no! I bow to thee, deeply! Commented Feb 8, 2022 at 23:49
11

Using the WindowsT key combination, you can bring up the taskbar even if it's stuck hidden. Not the most-ideal solution, but one that consistently works.

6
  • I wonder if this works in this situation?
    – Malachi
    Commented Nov 8, 2013 at 22:40
  • Like the Windows key on its own, or Ctrl-ESC, which I both mentioned in the question, Windows-T is a workaround. The difference is that Windows-T shows just the task bar, while the Windows key on its own shows the start menu in addition to the task bar. Commented Feb 21, 2014 at 11:50
  • I see what you're saying. That works really well in Windows 7. In Windows 8 and 8.1, it will bring up the start screen so you got nothin' in terms of a taskbar. I agree these are all workarounds to a larger bug that is z-indexing the taskbar and would love to see a native solution :).
    – Sawtaytoes
    Commented Feb 21, 2014 at 17:12
  • 1
    In Windows 8 and 8.1 the taskbar is being shown with Windows-T, thanks
    – Metafaniel
    Commented Jul 1, 2015 at 14:13
  • Pressing the Windows button also makes the taskbar pop up so its not really a solution, just a variation of something already known.
    – Don King
    Commented Apr 29, 2017 at 15:18
6

it looks like this is already a reported bug, I only post this for you because it looks similar to the issue you are having.

this is from the Eclipse bug site Bug 24052

looks like there is a post on a windows 7 forum as well

Taskbar auto-hide

4
  • 2
    "Similar" is an understatement, the reports in that Eclipse Bug record sound exactly like the issue I'm having. Thanks for reporting this! Commented Oct 16, 2012 at 19:20
  • this was already reported. I didn't report it. but you are welcome.
    – Malachi
    Commented Oct 16, 2012 at 19:41
  • 1
    Well, I meant "thanks for reporting the existence of the Eclipse Bug record". :-) Commented Oct 18, 2012 at 17:46
  • I am trying to find a more recent bug report. that forum entry just sounds like a bunch of people complaining and not really any solutions, or bug report status updates.
    – Malachi
    Commented Oct 18, 2012 at 18:00
2

I've been experiencing the exact same issue for years. Haven't found the reason or how to fix it, but you might want to try out the following workaround:

AutoHotkey script

~LButton::
coordmode, mouse, screen
mousegetpos, mX, mY
if mY = 767 ; THIS HAS TO BE YOUR CURRENT SCREEN HEIGHT RESOLUTION. can also be " > 750 " or sth. like that
{
    send #t
    send {Lbutton up}
}
return

best would be to put this in your autostart. This helps you in the following way: If your mouse is at the very bottom of your screen and the task bar does not come up: Simply click once and it will appear (win+t is being pressed by ahk)

PS. I would have loved to upvote the starter's post, but I cannot because of missing reputation.

1

I have the same issue, and 1 manage to find that with firefox regular version (i got the developers) the layer in which appears is in front of the one of the task bar thus making it impossible to appear... the solution is obvious dont maximize to the fullest.

1
1

Based on phil294's answer, here is an AutoHotkey script that doesn't require you to click with your mouse, but just works by moving your mouse to the bottom of the screen (as usual).

Just after the top of this script, you can specify the group of applications, which block the taskbar un-hide. The script activates only for these applications, so it shouldn't cause any unwanted trouble.

#NoEnv  ; Recommended for performance and compatibility with future AutoHotkey releases.
; #Warn  ; Enable warnings to assist with detecting common errors.
SendMode Input  ; Recommended for new scripts due to its superior speed and reliability.
SetWorkingDir %A_ScriptDir%  ; Ensures a consistent starting directory.

; Group of applications that block unhiding the taskbar
GroupAdd, groupBlocksHiddenTaskbar, ahk_exe editors.exe ; OnlyOffice
GroupAdd, groupBlocksHiddenTaskbar, ahk_exe FL64.exe ; FL Studio
GroupAdd, groupBlocksHiddenTaskbar, ahk_exe draw.io.exe ; Draw.io

; Show hidden taskbar
SetTimer, checkMousePos, 50
Return
checkMousePos:
    If Not WinActive("ahk_group groupBlocksHiddenTaskbar")
        Return
    Coordmode, mouse, screen
    MouseGetPos, x, y
    If y > 1078 ; Screen height (minus tolerance)
    {
        SendInput, #t
        SendInput, {Escape}
        Sleep, 50
    }
    Return

Note: make sure that you run AutoHotkey as administrator, otherwise it won't work for some applications.


If you haven't used AutoHotkey before, here is a step-by-step guide of what you have to do:

  1. Download and install AutoHotkey (not v2).

  2. Anywhere on your Computer, create a new AutoHotkey script file (file extension .ahk), e.g. myscript.ahk.

  3. Open myscript.ahk in a text editor, copy the above code, paste it to the file and save it.

  4. Double-click myscript.ahk to run it.


  1. To run the script as administrator, you need to locate your AutoHotkey.exe (Usually in C:\Program Files\AutoHotkey) and check Run as administrator under its properties.

  2. To run the script as administrator automatically on startup, you need to create a scheduled task for your script file (see this answer).

1
  • To me, the main downside of this solution (besides the inefficient polling) is that it will not just show the taskbar, it will also activate it, which will steal focus away from the application the user is currently working on. Commented Feb 6, 2022 at 21:05
0

the Task Bar is an application with a process, when you are not using it (when it's hidden) windows marks it as inactive and allows the CPU to use that processing power for all the other applications you are using, so you might see a lag when you try to activate the Task Bar again because Windows needs to re-allocate processing power to the Task Bar, and depending on how many applications or Processes are running will figure into the Task Bar not responding and for how long.

Edit

I know that FireFox and Eclipse eat up a lot of CPU especially Eclipse (at least the last time that I used Eclipse it did)

8
  • Note FireFox is one of the Heavier Browsers. everytime I use it on Linux or Windows it takes longer to load than Chrome and Even IE, I believe it hogs Processing also, a lot more than Chrome or IE
    – Malachi
    Commented Oct 4, 2012 at 16:13
  • 1
    @kmote if there was something that was set to Always on Top it would always be on top and OP would not be able to see anyother windows either, OP would notice what program was causing the issue.
    – Malachi
    Commented Oct 4, 2012 at 18:51
  • 1
    are you using Dual Screens? where is the Task Bar Anchored?
    – Malachi
    Commented Oct 4, 2012 at 18:57
  • When the problem hits, the task bar appears to not raise at all, no matter how long I wait. Yes, some of the apps can hog resources, but my system is otherwise responsive enough (sub-second). Commented Oct 5, 2012 at 8:08
  • I do sometimes use dual screen, but the issue also occurs when I have only one connected. Regarding "@kmote", when the program that is already on top (especially maximized), I might not notice if it is temporarily set to "on top". Commented Oct 5, 2012 at 8:19
0

The problem is with windows scaling.. if you have customized your display settings to magnify windows for easier viewing above 100% Windows doesnt think your mouse is really at the bottom of the screen calling for the hidden taskbar even though it really is.(definitely a Bug). I was able to fix by changing windows scaling back down to 100%..This isnt really a fix for those who need to visually magnify windows to see better.. just my observation of why the hidden taskbar wont appear when any app is in full screen mode when u have custom display settings.

6
  • But if this were the OP’s issue,  wouldn’t the problem be easily reproducible? Commented Aug 9, 2017 at 7:38
  • it should be...try changing your display setting to 125% (may require restart) ..set the taskbar to autohide..then open up any browser or pdf in full screen..the tasbar wont show unless u minimize.. wont work while in fullscreen..everything goes back to normal when u change your display scaling back to 100% or less
    – TeMpTeK
    Commented Aug 9, 2017 at 17:36
  • Thanks for responding. FYI, I wasn't interested in reproducing it myself; I was looking back at the OP's statement, “I am unable to directly reproduce this behavior.” Maybe I just don't understand your answer, but, to the best of my understanding, if the user has customized their display settings to magnify windows for easier viewing above 100%, then the taskbar would never reappear (until they changed the display setting back to 100%). So, if somebody had this problem, they wouldn't say “it appears to happen out of the blue.” Commented Aug 9, 2017 at 23:14
  • I think most ppl who have this problem do not realize that its because they have changed their display setting.. I was one of them..
    – TeMpTeK
    Commented Aug 10, 2017 at 3:22
  • +1 for helping to narrow this down. On the Windows 7 and XP systems that I had used when I asked the question, I had manually set the scaling to around 125%, so that at "zoom 100%", screen size matched print size (physical screen resolution was higher, a laptop). So it is possible that this setting has played a role. On Win8.1 (don't have Win7 any more), when I F11 to full-screen in Firefox, if task bar is not auto-hidden, there is no task bar, period. Thus I do not expect it to pop up when auto-hidden. On Win8.1, setting scaling to "recommended" (which is huge) did not change the behavior. Commented Aug 10, 2017 at 7:21
0

I just had this issue on a new laptop with Windows 11 with dual monitors.

I've always previously chosen to have the Taskbar on all screens but I decided to see what it was like with it just on one screen. I'm not sure if that was the trigger for the problem.

After my battery died and it woke back from hibernation, the Taskbar was hidden under the maximized windows on my second screen. At the time I didn't search for answers and just nudged the window layout slightly in the Display control panel. When it refreshed it came back in the right position.

enter image description here

-1

I know this is a pretty old question, but here's how I fixed my issue. Recently, my taskbar (set to auto hide) would no longer pop up when I dragged my mouse pointer to the bottom of the screen, as long as any app at all was in full screen mode. If I had apps minimized or in less than full screen, it would work fine.

To fix it, this is what I did.

1: Open and right click the taskbar, and make sure that "lock the taskbar" is not checked.

2: Open any app and make it full screen.

3: Use windows key to pop open the taskbar. Click on the taskbar and drag it to any other docking location (side or top) and release it. Then drag it back down to the bottom and dock it again. Make sure you are doing this while you have your app open full screen.

4: Taskbar should now pop open when you mouse down to bottom of screen, even if apps are open full screen. You can reset the property of taskbar to locked again, if that's the way you had it before.

Hope this helps someone.

-2

I have this issue. I found out when it's "stuck" hiding, it actually just ended up behind a window. If I change the window size then click the task bar it's fine again. Windows Key also works since it brings up the start menu and task bar. I think it's just a bug in windows. Annoying, but it doesn't stop functionality.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .