14

I'm trying to install the GitHub for Windows that I downloaded from the GitHub site. However, I get the following error message:

Application cannot be started. Contact the application vendor.

I'm curious if anyone else has ran into this issue, and knows of a fix?

Below is the info from the log file:

PLATFORM VERSION INFO Windows : 6.1.7601.65536 (Win32NT) Common Language Runtime : 4.0.30319.17929 System.Deployment.dll : 4.0.30319.17929 built by: FX45RTMREL clr.dll : 4.0.30319.17929 built by: FX45RTMREL dfdll.dll : 4.0.30319.17929 built by: FX45RTMREL dfshim.dll : 4.0.41209.0 (Main.041209-0000)

SOURCES Deployment url : github-windows.s3.amazonaws.com/GitHub.application

ERROR SUMMARY Below is a summary of the errors, details of these errors are listed later in the log. * Activation of http://github-windows.s3.amazonaws.com/GitHub.application resulted in exception. Following failure messages were detected: + The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

COMPONENT STORE TRANSACTION FAILURE SUMMARY No transaction error was detected.

WARNINGS There were no warnings during this operation.

OPERATION PROGRESS STATUS * [10/4/2012 12:22:45 PM] : Activation of http://github-windows.s3.amazonaws.com/GitHub.application has started.

ERROR DETAILS Following errors were detected during this operation. * [10/4/2012 12:22:45 PM] System.IO.FileNotFoundException - The system cannot find the file specified. (Exception from HRESULT: 0x80070002) - Source: System.Deployment - Stack trace: at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore(UInt32 Flags, IntPtr hToken, Guid& riid) at System.Deployment.Internal.Isolation.IsolationInterop.GetUserStore() at System.Deployment.Application.ComponentStore..ctor(ComponentStoreType storeType, SubscriptionStore subStore) at System.Deployment.Application.SubscriptionStore..ctor(String deployPath, String tempPath, ComponentStoreType storeType) at System.Deployment.Application.SubscriptionStore.get_CurrentUser() at System.Deployment.Application.ApplicationActivator.PerformDeploymentActivation(Uri activationUri, Boolean isShortcut, String textualSubId, String deploymentProviderUrlFromExtension, BrowserSettings browserSettings, String& errorPageUrl) at System.Deployment.Application.ApplicationActivator.ActivateDeploymentWorker(Object state)

COMPONENT STORE TRANSACTION DETAILS No transaction information is available.

It seems like the error message itself isn't specific to Git, but more of a universal message that Windows installer throws because I noticed when doing a Google search people trying to install other applications had an identical error message.

I wasn't able to find any information on GitHub's website about this error either. :(

Thanks for any help-

6
  • It looks like maybe you need to install .NET 4.5, or possibly reinstall .NET 4.5? Are you able to run other .NET programs?
    – Mark Allen
    Oct 4, 2012 at 18:21
  • 1
    Darn, too easy I suppose. Just even clicking your link in that log file (github-windows.s3.amazonaws.com/GitHub.application) was enough to launch GitHUB for me, which I already had installed. If you click that link, does it even try to do something?
    – Mark Allen
    Oct 4, 2012 at 21:50
  • 2
    I've tried running that too, but I get the same error. I believe the error is actually "Click Once" app related, and not GitHub itself. So far, GitHub support hasn't been able to help me with this issue either.
    – snowBlind
    Oct 8, 2012 at 19:34
  • 1
    That's actually good news - now you can try a bunch of fixes specific to that: social.msdn.microsoft.com/Forums/en/winformssetup/thread/…
    – Mark Allen
    Oct 8, 2012 at 19:47
  • 1
    Adding the possible solution as an 'answer' just in case it helps.
    – Mark Allen
    Oct 8, 2012 at 19:47

1 Answer 1

16
  • From the Windows Start Menu, choose "Run" (or type Windows (Windows Key)+R).
  • Enter the following, depending on your version of Windows, then click the "OK" button:

    • On Windows XP:

      %userprofile%\Local Settings\Apps 
      

      (which may be C:\Documents & Settings\(your username)\Local Settings\Apps)

    • On Windows VISTA / 7:

      %userprofile%\AppData\Local\Apps
      

      or

      %LocalAppData%\Apps
      

      (e.g., C:\Users\(your username)\AppData\Local\Apps)

  • Delete the 2.0 folder

6
  • Set to community wiki because I copy/pasted this from somewhere else.
    – Mark Allen
    Oct 8, 2012 at 19:48
  • 1
    I tried this with no luck a few days ago.
    – snowBlind
    Oct 9, 2012 at 15:23
  • Well it was worth a shot, sorry. :( I'd still pursue solving ClickOnce applications not starting in general, that does seem to be the actual problem.
    – Mark Allen
    Oct 9, 2012 at 17:25
  • 2
    This fixed my issue. Having a similar problem with the same message on Windows 8. Aug 29, 2013 at 18:52
  • It tried it, but does not work for me. It still shows the error : Unable to retrieve application files. Files corrupt in deployment.
    – Vishwas
    Feb 8, 2014 at 18:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .