I'm looking for help with a Vista Home Premium laptop that has trouble accessing any resource on our home network, but accesses the Internet just fine.

The set-up is this: The Vista laptop and a MacBook Pro connect wirelessly to the router-modem. A Synology DS212j NAS drive has a wired connection to the router-modem. Devices on the local network are always referred to by IP address, so this cannot be a DNS issue.

The MacBook Pro connects reliably to the NAS via AFP (network shared folders), SMB (network shared folders) and HTTP.

The Vista laptop connects to and browses sites on the Internet without any problems.

It can log into the NAS via SMB and list the shared folders (so there is nothing wrong with the log-in credentials), but when it tries to open any of the folders Explorer just hangs with the spinning cursor for several minutes and then says "\\shared\Photos is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. The specified network name is no longer available."

It can ping the NAS successfully.

If I try to open the NAS drive's web interface, the browser just hangs. This is the same with IE, Firefox and Chrome. (There is no proxy.)

I can log into the NAS drive with FTP and navigate directories, but when I try to list the contents of a directory with more than a handful of entries, the ftp client hangs.

I set up a website on the MacBook. The Vista laptop was able to load some of the pages, but loading any of the images was very hit and miss. Images embedded in HTML pages never worked no matter how many times I reloaded the page, but when I linked directly to the image it did load (though several attempts were sometimes needed).

I tried all of this with the Windows Firewall turned off, and with AVG turned off. That made no difference.

I'd really appreciate any suggestions anyone can make. The fact that the Vista laptop has trouble with HTTP and FTP as well as SMB connections suggests to me that this is a problem at the TCP level or below. But don't forget it accesses sites outside the LAN with no problems.

New 7 Oct

The Vista laptop has no trouble reaching the NAS drive if I disable the wireless NIC and connect by wired Ethernet.

(Remember also that WiFi works fine when accessing resources outside the LAN. It's only on the LAN that the problem exists.)

  • 1
    Did you check the setting for file sharing? Control Panel>Networking and Internet>Network and Sharing Center - Turn on File Sharing.
    – Tillman32
    Oct 4 '12 at 20:45
  • @Tillman32 Why would I want file sharing on? How would that help (especially with loading web sites)?
    – Ian Goldby
    Oct 5 '12 at 7:07
  • do any of the devices: Mac/Nas have any information in the logs that indicate that there was an error?
    – Ben West
    Oct 6 '12 at 19:56
  • You could try to create another user account on the NAS and see if this changes anything.
    – harrymc
    Oct 7 '12 at 7:57
  • @BenWest Good suggestion. The NAS does have a log, but unfortunately it isn't showing any error or warning. I get "CIFS client [Rachel] from [RACHELS-LAPTOP(IP:192,168,1,66)] accessed the shared folder [shared]." This is the same message I see when the MacBook accesses it (via CIFS if I choose that rather than AFP). But one can open the contained folders and the other can't. There are similar unhelpful logs for FTP access. Sadly no log for HTTP access.
    – Ian Goldby
    Oct 7 '12 at 11:51

I had the same problem no long ago with an user connecting mint using wired but unable to see local resources via WLAN.

It turned out to be an enabled feature called 'Client Isolation" on her Netgear Wireless Router.

This function works for Guests networks in order to allow them to certainly browse the web without sniffing at share drives, printers, etc.

I think you may want to give a look to your wireless router.

  • It turned out finally that there is a bug in the modem-router firmware. (It was a Thomson Speedtouch 585 version 5.) Effectively it was doing client isolation, but accidentally and randomly, with no setting to modify the behaviour available. A few others had observed the same problem but because it is such a old router there's no firmware update to fix it. Replacing it with a new router fixed the problem.
    – Ian Goldby
    Feb 25 '13 at 8:33

Also, I don't use Vista but IIRC there is an option to configure your connection type as 'Home' or 'Public'. Choosing the 'Public' option may disable access to resources in the local network. I suggest you check what type of connection you have to your Home lan, and that it is the correct type.

See also: http://www.vistax64.com/tutorials/124812-network-location-type-change.html

  • Thanks for the suggest. Yeah, it's set to Private already (what I think you meant by 'Home').
    – Ian Goldby
    Oct 7 '12 at 11:54
  • Have you tried any of the other network modes? office, for example (If Available) might allow more types of connection; I haven't been able to find good documentation on this anywhere.
    – Ben West
    Oct 8 '12 at 16:05
  • The other option is 'Public'. I just tried it and it is no great surprise to see that it made no difference, given that this setting has the same affect for a wireless and a wired connection.
    – Ian Goldby
    Oct 11 '12 at 19:12

Check the settings of the Windows Firewall with Advanced Security, Windows Firewall with Advanced Security blocks unauthorized network traffic flowing into or out of the local computer. Windows Firewall with Advanced Security also works with Network Awareness so that it can apply security settings appropriate to the types of networks to which the computer is connected. Now that Windows Firewall and Internet Protocol Security (IPsec) configuration settings are integrated into a single Microsoft Management Console (MMC) named Windows Firewall with Advanced Security, Windows Firewall also becomes an important part of your network’s isolation strategy.

When a user connects to a network that is not identifiable as a Domain location, Windows asks the user to designate the network as either Public or Private. The user must be a local administrator of the computer to designate the network as Private. When the type of network to which the computer is connected is identified, Windows can optimize some of its configuration, especially its firewall configuration, for the specified network location.

To configure system-wide firewall and IPsec properties, in the Overview pane, click Windows Firewall Properties. The Windows Firewall with Advanced Security on Local Computer. The tabs for each profile contain identical options. That control how Windows Firewall with Advanced Security operates when the computer is connected to that type of network. Note that when Group Policy is used to configure some settings, the user is notified by the message at the top of the dialog box, and the affected controls are disabled.


It is possible that the problem is caused by the new network feature that was introduced in Vista :
Receive Window Auto-Tuning Level for TCP connections.

See this article for details and for how to disable it: Disable TCP Auto-Tuning to Solve Slow Network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.