25

I cant scp, the other server only takes sftp connections.

Currently, I am trying to do

sftp jay@server.name.com:/files> put -r ~/

-i keyname does not work, just resolves with illegal option -- i.

migrated from stackoverflow.com Oct 4 '12 at 20:50

This question came from our site for professional and enthusiast programmers.

33

Try:

sftp -o "IdentityFile=keyname" jay@server.name.com

You can use -o to pass any option that's valid in ~/.ssh/config.

  • Nailed it. thanks! how do i keep it there normally? – Jay Oct 5 '12 at 0:00
  • I don't know what you mean by "keep it there normally". If you mean that you want the IdentityFile option to always automatically be given, check out UtahJarhead's answer about putting it in ~/.ssh/config – Celada Oct 5 '12 at 1:38
3

Copy your PUBLIC key to the server using traditional means.

On server:

  • Create .ssh if it doesn't exist:
[[ ! -d "${HOME}/.ssh" ]] && mkdir -p "${HOME}/.ssh"
  • Implement the public key:
cat /path/to/public_key.pub >> "${HOME}/.ssh/authorized_keys"
  • Set appropriate permissions. OpenSSH is VERY ANAL about the permissions of the files in question:
chmod go-rwx "${HOME}" "${HOME}/.ssh/authorized_keys"

After that, you should be able to log in from the client using the PRIVATE key. To automate a transfer, you want to use a batch file, which is just a text file containing a list of commands to execute.

echo "put filename.foo /safe/path/filename.foo" >> /tmp/batchfile.txt
sftp -b /tmp/batchfile.txt -oIdentityFile=/path/to/private_key user@host

Alternatively, feel free to create a ~/.ssh/config file in ssh_config format so you can just type this in the future:

sftp -b /tmp/batchfile.txt host

Sample contents of ~/.ssh/config

Host the_hostname
    User user_name
    IdentityFile /path/to/private_key
  • Ill try this on the next batch, the solution above did the trick though. – Jay Oct 5 '12 at 0:01
1

If you are looking to setup sftp on ec2, this article might help

  • Sorry, it really didnt. – Jay Oct 5 '12 at 0:01
  • 1
    This "answer" has nothing to contribute to the question. Worse, it is just a link to a page that will someday disappear. – John Mayor Oct 2 '16 at 20:57
0

I got into this issue recently and what worked for me in my macbook default terminal setup is the following

sftp -i ./privateFilePath.key username@url.com

Note you might be promoted with UNPROTECTED PRIVATE KEY FILE! message in which case you need to run this command to make sure your private key is not accessible by others.

chmod 600 privateFilePath.key 

In some cases you need to put sudo in front of the command, this is only if you are working in a admin protected directory

I wish thats helpful :)

  • Why do you expect this to be helpful when the question said that the -i option is not working? – Scott Aug 6 '18 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.