My USB flash drive is currently unusable because it somehow (quite suddenly!) became write protected. I have googled around and tried many solutions to this problem, but none of them have worked so far. Here are some of the solutions I've tried:

  • The drive has no tangible switch or button.
  • Formatting the drive won't work, even in command line, even "low level formatting", because the drive is (after all) write protected.
  • Changing certain registry keys to 0 doesn't seem to work.
  • Repair_Neo2.9.exe says "USB Flash Disk not found!"

One factor that may make it more difficult to find a solution: I have no idea what the make or model is, because I received the USB flash drive from my university as a gift. So if anyone knows how to find the make and model, that alone might be helpful.

Any ideas? Thanks.


5 Answers 5


Have you tried in linux version like Ubuntu/Fedora?

I had experienced this problem some years back and I plugged that USB flash drive in one of my linux live CD and formatted the drive and it worked well.

  • Unfortunately, I don't know the first thing about linux. I'm operating in Windows 7.
    – 97847658
    Oct 5, 2012 at 6:26
  • 1
    You can download a live CD of any distro to use without installation. Ubuntu's is here. Boot from the CD, plug in your device, and enter 'Disk Utility' in the Dash search bar. This will give you the option to format the device in whatever filesystem you like.
    – jam
    Oct 5, 2012 at 7:00
  • 2
    Note to the above comment: You can do all this without modifying your system at all. It will be back to normal once you reboot and take out the live CD (or live USB).
    – pzkpfw
    Oct 7, 2012 at 17:32

Here is the solution to remove write protection in pen drive. please do the following steps

Start -> Run -> Regedit -> HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\control\storagedevicepolicies

Edit the modify the binary data set value '0'

After editing, complete the GPupdate in cmd.exe.


If you can access the files, you may be facing a lack of permission to do more than that. You can check the permission level and change it to see if that give you full access to the drive.

  • Go to Computer
  • Right click your thumb drive
  • Click on Properties
  • Click the Security tab
  • Select Everyone and click the Edit button in the dialoge box
  • In the Allow column, check the Full Control box
  • Click Apply and OK

This should ensure that Access Control is ruled out as the souce of the Write Protected situation.

OR -

Use DiskPart Open a command prompt window for the windows version you are using

  • In the command prompt type diskpart
  • Type list volume to identify the thumb drives volume #.
  • Type select volume # where # is your thumb drives # and press enter.
  • Type attributes disk clear readonly press enter. You should get text back saying Disk attributes cleared successfully

Remove the thumb drive, then reinsert into USB.

Check the drive in question, you should now be able to access the disk with full permissions.

  • Thanks for your suggestion, but there is no Security tab, there's only General, Tools, Hardware, Sharing, and Customize. Any ideas?
    – 97847658
    Oct 6, 2012 at 20:45
  • @97847658 - yes. your thumb dive is formatted either in FAT or FAT32 so you will have no Security tab. But we can change that ;). Can you access the info on the usb drive and move it safely to your hard drive?
    – Carl B
    Oct 6, 2012 at 21:13
  • None of the data on my USB drive is needed, so it's okay if I lose it all.
    – 97847658
    Oct 6, 2012 at 22:36
  • Then format it. Right click the drive and select format. Select the NTSF under the file system option and click start. Then see if you know have access to the drive to put what you want on it and then pull off of it as a test.
    – Carl B
    Oct 6, 2012 at 23:17
  • Unfortunately, as stated in my original question, I'm unable to format it. When I select NTFS, click Start, and click OK, it gives me the error message "The disk is write protected." Or am I doing something wrong? Thanks.
    – 97847658
    Oct 7, 2012 at 7:22

I have this problem all the time with a WD external USB drive on my laptop running Windows 7. I used the DISKPART suggestion above but after I unplugged and reconnected the USB drive I still had the problem.

So I redid the DISKPART – remove readonly attributes and immediately ran a FORMAT on the USB drive. That worked.

I fully expect this problem will reoccur. Something is going on where the USB drive is being set to "write protect" by the Windows OS. Very strange.


I made it in Diskpart, but the media had a virus, so this is the out screen:

Disk 1 is now the selected disk.

DISKPART> attributes disk clear readonly

Disk attributes cleared successfully.

DISKPART> attributes disk
***Current Read-only State : Yes***
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .