12

Im using a Lenovo ThinkPad T420 with Windows 7 64-bit and my integrated webcam is not working. Skype settings always show an error (see below). I tried to install this driver but it didn't work.

Skype settings of Lenove T420

Any help?

Update: Result of Fn+F6

Here is the screenshot of that

Resized to 75%

It means something wrong with my the integrated camera. But any solution? Or suggestion that might help?

2
  • Could you please clarify, what happened when you tried to install the driver, the installation failed or what? – Serge Oct 5 '12 at 9:17
  • Well it just installed and prompted me for restart. Then after restarting I checked this settings again and found same. – Samiron Oct 5 '12 at 9:56

11 Answers 11

6

had the same issue with the same configuration - t420, win 64bit, had the lenovo-suggested driver installed (and re-reinstalled) and camera wasn't working, with same behavior as described in your issue and picture.
for my case, an addition to the behavior described is: when i had the communication settings screen open (i.e. where the camera should appear but didn't), the camera's green Led was lit, suggesting it's started.

searched about it quite a bit, and finally now i did something simple - uninstalled camera from the device manager . refreshed the device manager and automatically the camera got reinstalled under the default Win driver. Ta Daaaaaa... camera's working now.
i guess it's not the top performance/quality that the manufacturer's driver should've offered, but... at least it works.

i don't know to what extent this trivial solution works on your case, nor if you tried it already, but hope it helps.
now i'm still curious what happens if i reinstall the lenovo camera driver. i'll try that too.

1
  • I already lost hope for this to work and adapted my life to work without camera or with external camera in extreme situations. But after reading your answer I tried to check up once again and found my camera is working!! Thing is meanwhile I upgraded my system from win7 to win8. Probably thats when the driver problems are fixed. I dont know.. but somehow your answer seems to be closer with the original solution (which I dont know either) hence accepting it. – Samiron Jun 15 '14 at 11:36
11

I now it's rather late to post any answers here, but I just had the same problem and the solution is actually much less cumbersome than all the answers so far. The camera is in privacy mode (obviously it likes to change that by itself) and you can turn it back to normal by just clicking "show my video image" in the settings page visible on the screenshot posted in the question.

You get to this settings page by opening Lenovo - Web Conferencing.

1
  • ah ha... seems like really a good point. Because now I can remember I had some of those lenovo utility softwares installed at that time. And after movin to Windows 8, I didnt install those softwares yet. Probably thats why the camera is working by default. Will give update if I get those utility softwares installed again and found the problem same as you described. – Samiron Aug 29 '14 at 2:46
4

Check your Lenovo settings menu, go to camera settings, and make sure you are set to normal instead of private.

1
  • I didnt understand where to look for Lenovo settings menu. Would you please help me on that? – Samiron Feb 15 '13 at 7:49
3

The integrated camera does NOT appear to be supported in Windows 8. Look at the driver page for the Lenovo T420. You will notice that there are Windows 8 drivers for many devices. Under the camera and card reader section, Windows 7 (32-bit, 64-bit), Vista (32-bit, 64-bit), and XP are listed. Windows 8 is not.

You can try to install the Windows 7 driver, but barring that working, you are probably out of luck.

1
  • The fact that there are no windows 8 drivers on the site might simply mean that the Win8 drivers are not needed because they are already included in the OS. I find your answer a bit misleading. – slavmaf May 27 '14 at 6:20
1

Lenovo Tools

Lenovo makes a few tools that may work. Check out Lenovo's Driver grabber and the System Update Tool.

Driver Grabber - Handy tool for grabbing and extracting drivers Lenovo Lenovo Driver Grabber



System Update - A complete system updating tool, does BIOS, and critical windows updates too. LTSU5 Lenovo System Update

1

I had a problem with identical symptoms.

Turns out I was too strict in removing app camera permissions, and removed access to the LenovoUtility app.

Unfortunately, the LenovoUtility app is responsible for handling the "cut camera" Fn key, and removing its webcam access prevents it from controlling the privacy mode, making it impossible to disable privacy mode.

Giving back camera permissions to LenovoUtility fixed the bug.

0

Check that you have installed and are running CyberLink YouCam or software similar to that. If it is already running, exit it and try again.

8
  • Im sure that CyberLink YouCam is not installed. But usually i use CamtasiaRecorder to make tutorials which is kind of screen capturing software. Other than these I dont have any video recording softwares. But im stil not sure if any other installed software is creating the problem or not. – Samiron Oct 8 '12 at 2:53
  • Ok fine if possible update image of device manager. we can check that all device drivers are installed correctly or not. – Kumar Oct 8 '12 at 8:56
  • Since its a long list, i didnt want to spoil the page here. So click here to get the image of full Device List. – Samiron Oct 8 '12 at 9:13
  • @Samiron, Getting error 403 Error. Try to update to some other server. – Kumar Oct 8 '12 at 10:06
  • Sorry for that... here is the proper url goo.gl/RW9HE – Samiron Oct 8 '12 at 10:17
0

test the integrated camera with F6 - the Lenovo camera and sound control - when only the OS is running. Then you should get a view from the integrad camera, if it doesn't work, there is something wrong with integrated camera.

6
  • Ok i will try that – Samiron Oct 6 '12 at 9:34
  • How did it work? – FredrikD Oct 7 '12 at 13:40
  • I will be able to check it tomorrow. Its in my office machine. – Samiron Oct 7 '12 at 15:43
  • Ive added the picture after trying with Fn+F6. The problem exists here also. – Samiron Oct 8 '12 at 2:42
  • Have you contacted Lenovo support? The T420 should still have some warrany time left on it. – FredrikD Oct 12 '12 at 9:58
0

Just find 'settings' on your pc's Win 7 main screen (which shows all of your applications), change the status of 'Camera' from 'private' to 'normal' - and say hello to your own smiling face! I fixed my own camera in this way.

It may have nothing to do with your operating system. Do we really think Win 7 is so lame that it is incompatible to a camera? :)

0

You can get this to work by Selecting Show my video image option in the Lenovo - Web Conferencing utility.

I did not need to reinstall/remove any driver. It goes back to privacy mode by itself and Rather I accepted that because there's an option to keep the Web Conferencing utility in the system tray for easy access anytime (see image below).

The option in System Tray

I think Privacy Mode is a useful feature but introducing such a thing without an introduction is a very bad idea.

It is still ironic though that we need such a feature to keep a Webcam inactive after deactivating it on the UI. A lot of people would agree that this is a much needed feature to stay away from hackers.

-1

yes. also with me this simptom in a brand new lenovo T450 - and as simple as it was the solution - only change the status of the camera from "private" to "normal" - in the camera setting , that sould be in the capture video program that you use - skype/debut/atc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.