The Apple bluetooth wireless keyboard is installed on Windows, sometime it becomes unresponsive (meaning nothing that's typed in is received by the computer), but it becomes responsive again when I open the tab in Bluetooth Devices -> keyboard properties -> Services. Is there a solution to keep it responsive?


2 Answers 2


Because the Bluetooth wireless keyboard uses your Bluetooth adapter. Go to device manager, open the Properties menu of your Bluetooth adapter --> Power Management. Uncheck "Allow the computer to turn off this device to save power." Then the keyboard shouldn't turn off again.


I suggest first to fully patch your computer, also including optional updates in Windows Update.

Then find your keyboard in Device Manager, right-click and choose Properties, go to the Power Management tab and uncheck "Allow the computer to turn off this device to save power".

  • under keyboard, "allow the computer to turn off this device to save power" was checked off by default. And my bluetooth device doesn't that that option.
    – user22105
    Oct 27, 2012 at 17:08
  • Check in Control Panel / Power Option / Change plan settings / Change advanced power settings / Wireless Adapter Settings / Power Saving Mode. You may try to put it on Maximum Performance. If this doesn't help, maybe some other power setting may apply.
    – harrymc
    Oct 27, 2012 at 18:47
  • i've changed everything to "High Performance" keyboard sometimes is still unresponsive =(
    – user22105
    Oct 27, 2012 at 20:36
  • Only additional advice I can think of is (1) ensure your drivers are up to date, (2) try another keyboard to see if this is a hardware problem.
    – harrymc
    Oct 28, 2012 at 11:37
  • (1) device driver is up to date (2) no other keyboard to test if it's hardware problem...
    – user22105
    Oct 31, 2012 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.