Recently the scroll bars in all my applications on mac are growing larger when I hover over them and then covering the last item in lists (like Finder). Does anyone know how to turn this option off or in general if apple were to ever read this know of a better way to do this?

I think I would rather there be space at the bottom of the list for the scroll bar than for the scroll bar to covered the row (it can still remain hidden until necessary).

selecting bottom row


In System Preferences » General you can select Show scroll bars: Always. If you select that, applicable scrollbars are always displayed in their dedicated area, and don't resize when the pointer hovers over them.

Screenshot of scroll bars


It's one of the new features in Mountain Lion:

Improved scroll bars

Scroll bars in Mountain Lion expand when you hover the cursor over them, so it’s easier to scroll a web page or document.

I tried searching for hidden preferences for disabling it, but didn't find anything.

for f in $(mdfind kMDItemContentType==public.unix-executable -onlyin /System/Library/); do strings "$f" 2> /dev/null | grep -E '^[[:alnum:]_.-]{10,80}$' | grep -i scroll | sort -u | sed "s/^/${f##*/} /g"; done

  • I find it's getting in the way. What does "for f in $(mdfind kMDItemContentType==public.unix-executable..." mean? – 1.21 gigawatts Oct 6 '12 at 2:53
  • 1
    It's just the shell command I used for finding keys for hidden preferences. (I only tested a few of them though, so others could also give it a shot.) – Lri Oct 6 '12 at 6:23
  • 1
    FWIW, defaults read -g AppleShowScrollBars is either WhenScrolling, Always, or Automatic. Maybe that helps determining how it's used? – Daniel Beck Oct 7 '12 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.