I make some screencasts with my laptop. The software that I use in Ubuntu is GTK RecordMyDesktop which gives me an OGV file.

The quality is perfect and I am happy with it.

For publishing or giving it to other people though I need to do some minor video editing which I like to do it in OpenShot which gives me 1080p HD video hassle free. The problem is that is you import OGV to OpenShot the audio and video won't be in sync after the conversion and there are other compatibility problems with OGV in OpenShot as mentioned in other forums.

So, I need to convert it to a usable format in between. This conversion should be fast and lossless in order to import it in OpenShot and continue the workflow there.


1 Answer 1


I looked a little into the specifications and found that …

recordMyDesktop produces files using only open formats. These are theora for video and vorbis for audio, using the ogg container.

So, it's very likely that OpenShot has troubles parsing that container or either of these codecs. I would try and report a bug with OpenShot nonetheless, but if you want to try another container or video/audio codecs, you might succeed in parsing the videos without synchronization issues.

OpenShot uses FFmpeg's libraries for decoding, so chances are high it'll be able to parse anything you encoded using FFmpeg itself.

Your requirement was for the conversion to be lossless. This leaves two options:

  1. Change the container and keep the codecs, e.g. from OGV to MKV. I believe MKV is the only container that accepts both codecs you have.

    If you install a recent copy of FFmpeg (e.g. using a static build from here) — and please don't use the outdated version Ubuntu provides — then all you need to do is:

     ffmpeg -i input.ogv -c copy output.mkv

    Maybe that solves a problem related to OGV in OpenShot.

  2. Transcode the video and audio streams to lossless codecs, e.g. from Theora to lossless h.264 video and Vorbis to PCM audio.

    Again, using FFmpeg, this would be the following for lossless h.264 and PCM audio to a MKV container. Note that h.264 usually is not lossless, but -qp 0 will achieve that:

     ffmpeg -i input.ogv -c:v libx264 -qp 0 -c:a pcm_s16le out.mkv

    Or, using an MP4 container, which doesn't support PCM audio out of the box. We'll need to re-encode audio to AAC here and supply a little higher bitrate so as not to reduce quality too much:

     ffmpeg -i input.ogv -c:v libx264 -qp 0 -c:a aac -strict -2 -b:a 192k out.mp4

    Hopefully, that'll solve your issues. If not, filing a bug report with OpenShot would probably be the best solution.

If you get confused by the termini used here, please check out the following question: What is a Codec (e.g. DivX?), and how does it differ from a File Format (e.g. MPG)?, and for FFmpeg usage, read our related blog entry.

  • A through answer. Solution 1 worked out and also a bug report was sent. I wanted to look for the difference between the container/format until I saw your links at the bottom. It was great. Now I understand things much better.
    – rowman
    Commented Oct 8, 2012 at 15:49
  • 1
    The outcome of the bug report was that it won't get fixed because of the problems of vorbis codec with ffplay and melt .
    – rowman
    Commented Oct 9, 2012 at 7:32
  • Hm, that's interesting. Thanks for the update!
    – slhck
    Commented Oct 9, 2012 at 7:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .