I am using VMware workstation 8. I have attempted to install and run NetBSD 5.1.2 and 6.0. Installations all went OK and the system was usable until I install a window manager.

After installed xfce4, in NetBSD 5.1.2, I could startx and used xfce4 two times, however consecutive startx will hang and max all CPU to 100%.

In NetBSD 6.0 RC2, I could not even start xfce4 once, startx hangs and max all CPU to 100%.

I have tried to use both vmwlegacy and vmware device drivers, they don't help.

I have also tried both 32bit and 64bit NetBSD, they behave in the same way.

I also tried to catch the output of startx, however system was already hanging before the output gets flushed.

Apparently no one else has encountered these troubles on Google search, did I miss any configuration piece? Any other suggestions please?


I had similar problems also but if you build the modular Xorg in pkgsrc, that works fine. Although to use anything like gnome and friends, you'll have to build everything from pkgsrc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.