20

Gnome Shell by default uses the Super (Windows) key to display the activities overview. But I'd prefer to use the Super key to invoke Synapse. Right now I have to press Super+Super+Spacebar in order to invoke Synapse which is annoying (Super+Spacebar is the binding to invoke Synapse).

Is there any way to remove the default Gnome Shell mapping? In the keyboard shortcuts system settings, only the Alt+F1 binding appears for the activities overview action.

  • Even though I'd really like to know the answer to this question as well - this should be on superuser. – Omar Qureshi Jan 25 '12 at 10:17
  • go into the code of gnome shell and rip out the code that does the key binding. i could tell you which lines to comment out but i don't want to go digging in that mess. – Dan D. Jan 26 '12 at 15:44
18

I found how to do this here:

Start gconf-editor and set /apps/mutter/general/overlay_key to empty string, then restart gnome-shell.

From gnome-shell 3.4 onwards, use:

gsettings set org.gnome.mutter overlay-key ''
| improve this answer | |
  • 2
    Gnome 3.8: I was able to use "dconf editor" and change it from SUPER_L to SUPER_R to move it to the right side of the keyboard which is less obtrusive for me. Takes effect immediately, no need to log out. – sherbang Nov 20 '13 at 19:45
1

The way I got round this is in keyboard preferences to set the left windows key to be the meta key and left alt key to be alt.

This means that your left alt key is no longer a meta key - so if you use emacs, you'll need to either have to get used to that change rebind all your Meta keybinds to work on Alt instead.

| improve this answer | |
0

If you are on gnome-shell version lesser than 3.4, you can install dconf-editor and use that to disable the overlay-key.

In my case on RHEL 7.x and gnome-shell 3.28.x, I had installed dconf-editor using sudo yum install dconf-editor.

Launch dconf-editor GUI, search for overlay-key as shown here Searching for Overlay Key in dconf-editor.

After this two things needs to be done:

  1. Disable the 'Use Default Value' option.
  2. Set the 'Custom value' for overlay-key to blank.

Refer here Disabling 'Use default value' option and Setting 'Custom value' for overlay-key to blank. On applying the update, it reflects immediately.

After disabling 'Super_L' as overlay-key, you can launch Activities Overview by the other default gnome-shell key binding Alt+F1 (provided you have not overridden it)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy