I had few folders where the contents are missing (Desktop, Documents, Download, Files and a few folders from Library/Application Support). I also realized that those folders are the first few in my Users/~ folder.

I have listed the contents:

  • Desktop (gone empty)
  • Documents (gone empty)
  • Downloads (gone empty)
  • Files (gone empty along with many sub-folders)
  • Library (only few folders in Application Support has disappeared)
  • Movies
  • Music
  • Pictures
  • Public
  • Sites
  • Wine Files

Because there are 20-40GB worth of loss, I dont think it was deleted. I even used Disk Drill but the files are not there. Other than that, the folders: Movies-ZTEEVDO are still intact.

How do I recover these files and folders?

Additional Notes: I dont know if it helps but my launchpad is now messed up and a different icon I had for my Files folder changed into a regular folder icon.

  • Do you have any idea when this happened (approximately)? What caused you to notice it happened? What's in Console? What do your logs show (from console)? What version of OS X is this? What hardware is this (Mac Book Pro, iMac)? If it's OS X Lion or later have you tried booting into the recovery partition and running disk doctor? Do you have any backups? Do you have any external drives (that we can use to clone over to so that we can do some REALLY deep work on this drive)? – Everett Oct 8 '12 at 4:09
  • My guess is that I mis-pasted a terminal command. cd ~ mkdir mctmp cd mctmp jar xf ~/Library/Application Support/minecraft/bin/minecraft.jar rm META-INF/MOJANG_C.* jar uf ~/Library/Application Support/minecraft/bin/minecraft.jar ./ cd .. rm -rf mctmp I'm using 10.7 macbook. I dont have any backups and never tried running disk doctor or booting into the recovery partition (would you tell me what would/could happen if i do)? – Lena Oct 8 '12 at 4:48
  • Things you do in terminal don't delete through the trash can. They delete directly immediately. You'll need to use recovery software if at all possible ( alsoft.com/diskwarrior ). It's the only way to do a recovery that I'm aware of (if you don't have a backup). rm -rf done by itself may be what caused the problem. If you executed it on a command line without identifying what to delete (copied/pasted incorrectly), it will delete folders until 1) there aren't any left under the current structure 2) you stop it. – Everett Oct 8 '12 at 5:01
  • To enter the recovery partition you hold down command R on the keyboard while the computer is booting up. This likely won't do you any good, because disk doctor doesn't undelete files. My disk doctor recommendation is only useful if you aren't sure what the problem is. If there is a hard drive issue it will (likely) identify it. – Everett Oct 8 '12 at 5:03
  • 1
    "Stop it how?" Ctrl-C (this is the command for "break"). If the files were lost 24 hours ago, you can hope not much has changed over that time. Disk Warrior can read what's actually on a disk as long as it hasn't been written over. As for files taking a long time to delete... When you use rm you are telling the file system to forget where the folders/files are located. They aren't written over by using rm, just the index that tells the operating system where the files are is erased some. So hopefully Disk Warrior can still read the files and tell the file system how to recover them. – Everett Oct 8 '12 at 7:14

protected by Community Oct 25 '16 at 5:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.