My laptop (Asus X7BSV) is stuck using only the integrated GPU. It has a nVidia GT540M as well, but I cannot get it to work.

I am using a Windows 7 x64 with latest drivers.

This occurred after I attached an external USB monitor I need for work, and since then I cannot swap back to the nVidia GPU (dxdiag for example says that the primary GPU is the Intel integrated one).

Asus support asked me to completely reinstall the system, but that is something I do not want to do. I checked the BIOS, there is no option as to what GPU to use. The nVidia card itself is working, since I can use CUDA on it, and it worked with a Ubuntu Live CD. In the nVidia software management I tried setting it to global setting, high performance GPU (nVidia), but that had no impact.

What am I missing here? I did uninstall/delete all drivers and software related to the external monitor, but that did not help.

1 Answer 1


With my Latitude E6520 with Intel HD Graphics 3000, NVIDIA NVS 4200M, and Windows 7 Enterprise, I can use the NVIDIA Control Panel to force a specific processor per-application or globally. Try either:

  • Right clicking on the Desktop and selecting NVIDIA Control Panel
  • Navigating to the Control Panel and searching for NVIDIA Control Panel

If you don't have it installed, make sure you have the latest NVIDIA drivers.

enter image description here

Under the NVIDIA Control Panel, navigate to 3D Settings -> Manage 3D Settings. Select the Global Settings tab and use the Preferred graphics processor drop-down to select High-performance NVIDIA processor. Then hit the Apply button. You may need to restart your computer.

  • 1
    That setting no longer exists.
    – Mike Wise
    Jan 12, 2019 at 11:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .