20

I have a folder called C:\cygwin. How can I delete this folder.

It says I need permission from the administrator. However I am logged in as administrator.

  • You might need to use the sudo command, which is the *nix super user invocation. – martineau Oct 9 '12 at 7:15
4

If you get an error that an object is in use, then ensure that you've stopped all services and closed all Cygwin programs. If you get a 'Permission Denied' error then you will need to modify the permissions and/or ownership of the files or folders that are causing the error. For example, sometimes files used by system services end up owned by the SYSTEM account and not writable by regular users.

The quickest way to delete the entire tree if you run into this problem is to change the ownership of all files and folders to your account. To do this in Windows Explorer, right click on the root Cygwin folder, choose Properties, then the Security tab. If you are using Windows XP Home or Simple File Sharing, you will need to boot into Safe Mode to access the Security tab. Select Advanced, then go to the Owner tab and make sure your account is listed as the owner. Select the 'Replace owner on subcontainers and objects' checkbox and press Ok. After Explorer applies the changes you should be able to delete the entire tree in one operation.

If you want to be thorough you can delete the registry tree Software\Cygwin under HKEY_LOCAL_MACHINE and/or HKEY_CURRENT_USER. However, if you followed the directions above you will have already removed everything important. Typically only the installation directory has been stored in the registry at all.

Here is the source Cygwin Link

47

Open an cmd.exe as administrator:

takeown /f "c:\cygwin" /r /d Y

The last parameter makes takeown assume yes to all questions and depends on locale. In my locale I had to answer "J" to make it work. YMMV.

icacls "c:\cygwin" /T /Q /C /reset

Finally, to delete the files after we got the relevant permissions:

rd "c:\cygwin" /s /q

See https://serverfault.com/questions/43794/using-icacls-to-set-permissions-on-user-directories and http://lallousx86.wordpress.com/2009/06/14/resetting-ntfs-files-security-and-permission-in-windows-7/

Hope this works for you.

  • I had tried taking ownership, etc. and this is what finally worked for me! Thanks. – dub stylee Aug 12 '15 at 0:39
  • Excellent answer! could delete the cygwin folder after this. – Damian Feb 19 '17 at 12:21
  • This certainly worked for me too (and I thought I had tried pretty much everything everything by now!). – jony Jul 3 '17 at 0:26
  • Lifesaver! Had this issue for many years, in different ways. With the Cygwin folder itself when re-applying Windows OS installations, and/or moving them to new hard disks, and tonight, when I was simply creating folders with rsync inside of a Cygwin that I had installed fresh with my current OS install... – Pysis Dec 21 '17 at 3:20
  • aaaaand now, somehow, I've entered a worse scenario where performing the same action, while now using an fstab with noacls added, creates a folder where the owner cannot be viewed, changed, and the steps mentioned here failed for that reason as well. – Pysis Dec 21 '17 at 3:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.