Here's what I want:

  • Windows Narrator reads ONLY the text that I specifically tell it to read.
  • If I have not told it explicitly to read some text, it should stay silent.
  • Moreover, after I have told it to read some text, I can click elsewhere, type stuff, generally perform all other tasks, while it obediently continues reading out the text I told it to read.

Right now the problem is that wherever I click, Narrator starts yapping away. I can tell Narrator to read some specific text, but as soon as I try to do anything else, say click some other window, it stops reading what I told it to read, and instead reads what's in that window.

(It would be very surprising if there isn't any way to get the above simple request to work. But then again Microsoft never ceases to amaze.)

  • I never found a way to do this in Windows 7 Narrator anyway. I'm not sure if Windows 8 improved on it...
    – Mufasa
    Oct 28 '12 at 16:22
  • blogs.msdn.com/b/b8/archive/2012/02/14/… this should help. Oct 29 '12 at 0:36
  • Drake, this question was never properly answered. I'm looking for the same thing. Did you ever find a solution to this? Nov 5 '15 at 14:58
  • @BeanBagKing Hi, no never found how to do with narrator. Even with Windows 10 it didn't change the behavior described above
    – Drake
    Nov 5 '15 at 17:14

The easiest and most painless way to achieve this is copy-pasting the text to Notepad++ and using the “Speech” plugin (which uses the default Windows text-to-speech utility).

Personally I prefer this method because:

  • I can do other stuff while the text is being read without interrupting it
  • I don't have to mess with text selection (e.g., when I want to listen to text from websites I don't have to rely on software to check what belongs to the text and what is just unnecessary other stuff like comments/image-caption etc.)
  • I am able to pause/resume the speech

To install it:

  1. Pull down “Plugins” menu
  2. Select “Plugin Manager” > “Show Plugin Manager”
  3. In the “Available” tab scroll down until you see the “Speech” plugin
  4. Check the checkbox next to it and click the install button

To use it:

  1. Select the text within Notepad++ that you want spoken
  2. Pull down “Plugins” menu
  3. Click on “Speech”
  4. The submenu that comes up has commands to speak & pause/resume.
  • The speech plugin doesn't seem to be available from within Notepad++ any more. There's a build here: github.com/vinsworldcom/nppSpeechPlugin. In my case I found I already had a SpeechPlugin.dll from an earlier installation, but had to move it from C:\Program Files (x86)\Notepad++\plugins\ to C:\Program Files (x86)\Notepad++\plugins\SpeechPlugin\ for it to be detected (seems like a recent change to Notepad++).
    – swref
    May 30 '20 at 13:32
  1. To open the Narrator press Windows logo key + Enter.
  2. Caps Lock+Ctrl+U to read the current page
  3. Caps Lock+Ctrl+I to read the current paragraph

For detailed list of commands see: http://windows.microsoft.com/en-US/windows-8/hear-text-read-aloud-with-narrator

  • 1
    Using those shortcuts on Firefox text paragraph Narrator says "Not on explorable text".
    – Drake
    Nov 5 '12 at 13:26
  • 2
    Firefox is an MSAA application and currently does not implement UI Automation (UIA). A project was started to add UIA support to Firefox, see this blog post for details. Also you can track the progress of UIA implementation on bugzilla Nov 5 '12 at 13:56
  • I've checked out the link you specified and can get Narrator to read everything except the "meat" of the application. So it can navigate menus and toolbars, but can't even get it read the text of a MS Word 2010 Document. Have you actually had success getting Narrator to read anything?
    – Joel B
    Feb 5 '13 at 17:09
  • 1
    This does not answer the question.
    – user293098
    Aug 28 '15 at 3:50

It seems like narrator will sometimes read selected text just by selecting it with the mouse. If it doesn't, I try clicking somewhere inside the selected text, which sometimes works. If that doesn't work I try selecting the text again and clicking somewhere outside of the selection.

My current solution:

Within Narrator Settings >> Commands I changed the keyboard shortcuts for:

Read Next Paragraph CTRL+.

Read Previous Paragraph CTRL+,

This way I can select some text and hit these keystrokes to go back and forward between paragraphs.

I also have mapped the "Forward" and "Middle" buttons on my mouse to perform these keyboard combos so I can easily use only the mouse.


The Windows 10 magnifier app (open with hotkey Windows + M) has a text-to-speech (TTS) option (hotkey ctrl + alt + left click while magnifier is open). It puts a box around your selected text just like narrator does. You can set the magnifier to 100% magnification so you only use the TTS feature and not the magnification. You can also change the language of the TTS.

The only downside is that it doesn't solve your third bullet point. When you click elsewhere, the TTS stops. I don't see an option in Windows settings to change this.

Here's Microsoft's guide on using this feature.

There are probably TTS desktop applications that can do exactly what you want.

Not the answer you're looking for? Browse other questions tagged or ask your own question.