1

I am using SUSE Linux with gnome-2. My screensaver runs for 5 minutes and the screen goes blank after that. I want to disable the "Blank screen".

I tried the following commands:

$ setterm -blank 0
$ setterm -powerdown 0

I also added the following lines to etc/X11/xorg.conf under ServerFlags section

Option          "BlankTime"     "4"
Option          "StandbyTime"   "0"
Option          "SuspendTime"   "0"
Option          "OffTime"       "5"

But this did not work.

Any other suggestions?

  • I think setterm is the wrong command. – jww Feb 16 at 22:47
0

I'd have a poke around in the GUI config app (System Settings > Advanced > Power Management) and check your power options for your current profile. Sounds like 'Dim display when idle for x min' is turned on somewhere.

  • thanks.. but I have to do this in a script. I can't use GUI – Wasi Oct 10 '12 at 14:56
  • Why can't you change the settings via the GUI, out of interest? – jam Oct 10 '12 at 15:25
  • For GNOME3, changing the setting for one user does not appear to change the setting for the system. It leads to trouble on some machines, like needing to wait for the user to login so the ethernet connection comes up. Otherwise the machine stays in some low power state after reboot and SSH does not work. – jww Feb 16 at 22:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.