I want to use local scrollback on my terminal, whilst using gnu screen. That's because my network connection is incredibly slow, so using screen's scrollback is very slow. Local scrollback is much better.

This works, using "termcapinfo xterm* ti@:te@" in my .screenrc.

However, the mouse is mapped to screen's 'up'/'down' cursor keys, rather than being mapped to my local terminal scroll. Why? When screen is not running in the remote ssh session, using the mouse to scroll works just fine. But it seems like somehow gnu screen is telling my local terminal to just send it the mouse wheel commands, and ignore them itself?

3 Answers 3


Press Ctrl+A on the keyboard and press Esc.

Press the Up and Down arrow keys or the PgUp and PgDn keys to scroll through previous output.

Press Esc to exit scrollback mode.

In screen it is done this way because each virtual terminal has its own scrollback buffer.

So I don't think you'll be able to do it the way you want to do it using screen. I have heard that it is possible to use the mouse to scroll using byobu instead of screen. Frankly either byobu or tmux are better IMHO. I prefer tmux, never tried to scroll in it though.


Why you don't try just uninstall the gps2 package? It's the default package to manage mouse copy and paste using mouse at the xterm.

  • xterm can copy and paste itself but the question is about scrollback controlled by a mouse.Does gpsd really handle this? Nov 19, 2013 at 0:39

You can turn off Screen’s mouse tracking in the current session with a command:

Press Ctrl+A and type :mousetrack off

To keep this mode after detaching from and reattaching to this Screen session, use :defmousetrack off

To default to this mode for new Screen sessions, put defmousetrack off (without the leading colon) on a new line in your ~/.screenrc file.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .