I've got a hidden folder in .Trash on my flash drive called 501. Inside it, there are all kinds of programs. After re-reformatting the drive I had 2GB missing of the 8Gb. That's how I came across this. I checked the file permissions, tried sudo, I can't remove it. I was able to navigate inside the folder and empty the trash. It then dropped down to 2.7Mb of space, but when I add to the drive, then delete, the files are still stored in this 501 folder. Even after re-re-reformatting.

Is it possible to delete this folder? Or is this 2.7Mb really necessary to make the drive work? Why would I have to manually go into the folder and empty the trash after I already delete the files? It's bothering me because it seems to behave like a sophisticated virus.

  • since you are in unix, navigate to the trash folder and type ls -a. Now you can sudo rm filename, see if that does anything?
    – pneumatics
    Oct 10 '12 at 15:58

If it is a Mac, I finally was able to by, while on Finder, click on the Finder menu next to the Apple menu and select Empty Trash. Only the trash on that removable disk will be erased!


try deleting the volume, creating a new volume, and formatting it.

EDIT: In windows go to the disk manager (Right-click on my computer, click 'Manage', and select 'Disk Management') The disk should show up as a drive with an unknown file system. right-click on the partition and select delete partition until all partitions are gone. then right-click and create a new partition.

  • I've tried. I keep getting Resource busy
    – Eric Leroy
    Oct 10 '12 at 14:04
  • @Eric: Can you try deleting the partition in another OS?
    – Karan
    Oct 10 '12 at 14:07
  • Nope. It shows up as an empty drive in Windows. Like I said, I think it's a virus.
    – Eric Leroy
    Oct 10 '12 at 14:08
  • What does Disk Management (diskmgmt.msc) show? Maybe a GParted LiveCD will help. Also, here are some interesting links: 1 and 2.
    – Karan
    Oct 10 '12 at 14:10
  • @EricLeroy See the edit
    – Jeremy
    Oct 10 '12 at 15:41

Since you have tagged this with unix, I am going to assume you are using this thing under a linux/unix system. My suggestion would be to do an fdisk on the device to show what is under it. Then you can possibly delete the problem partition, and create new.

You realize that depending on the source, there could be Read ONLY memory on the flash drive. I have seen this sometimes in USB drives obtained as freebies from some companies wanting to keep their stuff always resident on the USB drive. Or it could be utilities that the vendor wants you not to erase for security purposes. This is a possibility.

  • not a character device or a regular file - is the error with fdisk. I was able to delete the .501 folder off the drive by reformatting it on a PC. Checking the device again on mac showed that the completely empty drive had no more hidden files / drives. The issue is when I add / delete a file, the .trash comes back up and when I try to delete, the process freezes. When I delete the file, it is still retained in the hidden files until I reformat. It's been making me think that it's a virus on my mac that transfers itself through flash drivers.
    – Eric Leroy
    Oct 10 '12 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.