My main HDD is failing to boot. (Neither Normal nor Safe mode). Single User seems to work. I can only boot from Recovery Mode or DVD.

The scenario was the following:

  • Computer was asleep (lid down).
  • Lifted the lid then connected USB mouse.
  • Mouse nor trackpad nor keyboard responded.
  • Closed the lid, removed the USB mouse then opened the lid again.
  • Trackpad and keyboard responsive once again, but after trying to close some programs computer freezes.
  • Shutdown computer by pressing power button for 10 seconds.
  • At restart computer doesn't boot anymore.

When booting in verbose I noticed the following:

USBMSC Identifier (non-unique): 000000009833 0x5ac 0x8403 0x9833
disk0s2: I/O error.
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Write] [PBlkNum 2] [FSLogMsgID 61471212] [FSLogMsgOrder First]
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [FSLogMsgID 61471212] [FSLogMsgOrder Last]
jnl: unknown-dev: update_fs_block: failed to update block 2 (ret 5)
jnl: unknown-dev: journal_open: Error replaying the journal!
hfs: early jnl init: failed to open/create the journal (retval 0)
Kernel is LP64
com.apple.launchd                       1          com.apple.launchd
com.apple.launchd                       1          com.apple.launchd
com.apple.launchd                       1          com.apple.launchd
** /dev/rdisk0s2 (NO WRITE)
** Root file system
   Executing fsck_hfs (version diskdev_cmds-557-393)
jnl: disk0s2: replay_journal: from 13043200 to: 3971072 (joffset 0x15502000)
disk0s2: I/O error.
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Write] [PBlkNum 2] [LBlkNum 2] [FSLogMsgID 1396728806] [FSLogMsgOrder First]
0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevMode devfs] [MountPth /dev] [Path /dev/disk0s2] [FSLogMsgID 1396728806] [FSLogMsgOrder Last]
jnl: disk0s2: update_fs_block: failed to update block 2 (ret 5)
jnl: disk0s2: journal_open: Error replaying the journal!
hfs_mount: journal_open == NULL; couldn't be opened on Macintosh HD
mount_hfs: Invalid argument
FIP USER Space POST: Integrity test failed!
BootCacheControl: could not unlink bootcache playlist /var/db/BootCache.playlist: 30 Read-only file system

After that it just gets stuck and never gets past that.

I booted in recovery mode then tried verify and repair disk with disk utilities put is seems to be OK. However Macintosh HD cannot be mounted.

Tried fsck_hfs from Recovery Mode terminal then got Macintosh HD cannot be repaired.

I'll want to know if there is anyway to rescue the system without reinstalling Mac OSX or at least a way to recover some filesfrom the drive before reinstalling Mac OSX.

  • 1
    Are you comfortable working on hardware and taking the HDD out? Do you have another machine that you can hook the drive up to? – jmreicha Oct 10 '12 at 21:02
  • I could try with a friend's if other methods fail to work – jonathanwiesel Oct 11 '12 at 5:24
  • Sorry, my bad. I actually can boot into single user mode. I'll try to backup my data from there – jonathanwiesel Oct 11 '12 at 5:34
  • I would reccomend removing the drive and backing it up on another machine, but if you have success in single user mode then that works too. – jmreicha Oct 11 '12 at 15:55

This may be a little more effort but I have had some success with a tool, Spinrite, that works below the level of to OS and file system. It runs on PC hardware. I have heard it work on Tivo and IPod drives which other file systems.

More the drive onto a pc if possible with a Sara or USB connection and run Spinrie on it. Level 4. Once done move it back and try to boot. It's $90 and a few hours work but may give you a chance at recovery


I managed to recover my data in single-user mode by mounting an external drive then copying the data to it, for people with similar problems I strongly recommend you to backup your info as soon as possible because after doing this I reformatted the drive then tried to reinstall Mac OSX just to find out that the drive was failing again. Long story short, the drive is dying... or, maybe dead... or more like a zombie veggie. Before his passing I tried to repair it with DiskWarrior but it didn't see the drive (probably because the drive couldn't be mounted); however DataRescue could see the drive and also retrieved a big hunch of data, some corrupt DMGs thou.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.