I have a computer running TightVNC server. It is on my home network. The computer it is installed on has a locally static ip address I am able to connect to this vnc server from my home network fine, but unable to connect from outside my network (using the IP address that I see at www.whatismyip.com).

I have forwarded port 5900 (and 5800) to ip address But if I use canyouseeme.org I am unable to see that port.

I am running Windows 7.

Any suggestions?

  • Did your ISP block 5900? You might want to check with them. Or try other ports.
    – caliban
    Sep 29 '09 at 17:48
  • check your router's firewall settings
    – John T
    Sep 29 '09 at 17:50
  • Are you using the TightVNC viewer or are you using the web based interface?
    – Stevoni
    Sep 29 '09 at 18:32
  • Tight VNC viewer
    – CT.
    Sep 29 '09 at 19:29
  • Are you receiving an error from the viewer? Have you tried using the web viewer? In the web browser type IpAddress:5800 and you should be able to get some sort of 404 or a TightVNC error.
    – Stevoni
    Sep 30 '09 at 2:12

I would double check that you have forwarded the port as that is all you should need to do.

If there is a problem, try changing the default port in case your ISP is blocking it.

Lastly, you may want to double check that you have forwarded the correct protocol, I can't remember if it is TCP or UDP that is needed, but if you have one - try the other (or both!)

2 is a private IP Address that you will never be able to access from outside your network. You need to use the IP address of your modem. Your router does address translation that sees your internally and when you send email or anything else on the net your router translates that IP into a public IP address that the "Cloud" understands. I do not know exactly how to set up TightVNC, but I do know that you need to be using your public address and not a private IP address. Hope this gets you going in the right direction.

  • 2
    Yes when I attempt to connect I use the external ip address of the router, not It is the same address I would see as if I went whatismyip.com
    – CT.
    Sep 29 '09 at 18:25
  • Then I apologize. I wish I knew the answer. I have tried to use TightVNC in the past, but I didn't have access to the router as it is a business router, so I just gave up. Good luck. Maybe you could post your solution when you find one. Sep 29 '09 at 19:03
  • Sites like whatismyip.com will show you the IP address of the proxy server, in case you use one.
    – Arjan
    Oct 3 '09 at 9:53

According to this, you need to forward a 5800 as well.

  • yes I have this forwarded as well
    – CT.
    Sep 29 '09 at 17:55

The IP you listed is assigned by the router. Instead of attempting to access this address, you need to get the IP address that you're router is assigned by the ISP.

My IP address is 66.xxx.xxx.90 so I would need to enter this information (rather than the 192 series IP) in order to access my computer using TightVNC.

Another solution to your problem would be to sign up for a domain name using DynDNS.com (or a similar site), download their software and make sure it updates. What this allows you to do is access your home network using something like MyDomain.Mine.nu (which is how mine is set up). It is much easier to remember a name you came up with than those silly useless numbers.


I just tried canyouseeme.org from here and it seems to work as expected: sees the ports I know are open, doesn't see ports I know are closed. So it seems like a good tool.

If it's saying your ports are still closed, your ports are still closed. This could be due to your ISP, or any device in your connection path. It could also be due to your VNC server not running, so make sure it's running before testing.

Here's some things to check:

  • Does Win7 have an active firewall? Could it be allowing local traffic on those ports but blocking external traffic? (If uncertain, disable it long enough to test.)
  • What router make/model are you using? Latest firmware? Any other users reporting problems with forwarding?
  • What's upstream from your router? Cable/DSL modem? Does it need to be configured to allow incoming traffic?

I'm betting (could be wrong) that you probably actually need to forward 5901/5801. Doesn't VNC add the display number to the port you select? The first display number is 1. Been awhile since I messed with VNC but just a thought.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.