I'm trying to set up a local repository so that all commitments are copied to the local destination, not a remote server. I followed this tutorial.

What I did.

  1. Created a folder named "SVN_Repo" under C:\Documents and Settings[user-name]\My Documents\
  2. Right clicked on the folder and chose TortoiseSVN -> Create repository here
  3. Clicked OK in the pop up dialog asking whether to create a directory structure.
  4. Created a folder named Repos for the local destination, under E:\
  5. Right clicked on the SVN_Repo folder and chose SVN Checkout...
  6. Typed file:///E:\repos in the URL of repository field and clicked the OK button.

    enter image description here

  7. What I got:

    Checkout from file:///E:/repos, revision HEAD, Fully recursive, Externals included

    Unable to connect to a repository at URL 'file:///E:/repos'

    Unable to open an ra_local session to URL

    Unable to open repository 'file:///E:/repos'

    enter image description here

I must be doing something wrong. Could somebody point it out? Thanks.


Until step #4 you were doing OK.

Step 5 should be - Right click Repos folder and choose SVN Checkout...

Step 6 should be - Type file:///C:\Documents and Settings[user-name]\My Documents\ in the URL of repository field and click the OK button.

Then you can copy files into your Repos folder (a better naming could be SourceCode folder) and check them in.


According to this page, https://stackoverflow.com/a/741664/1608619 ollifant (user) says,

The "Create repository here" action creates a repository which you can access locally via file://.. syntax or via the svnserve daemon.

The "Checkout" action can be done in any other place. You can either use a local repository, access a repository via http(s) or svnserve.

It seems I had to select Create repository here... for the destination folder. By doing this I've started getting no errors. And I could comit some files but the strange thing is that the destination folder does not have the exact same directory structure as the working directory.

To see if it is working, I created another directory and choose SVN Checkout from the context menu, and it surely synchronized the files with the other working directory previously created. So it seems it's working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.