4

I have 18 updates appearing for Windows 7 x64 but when I try to install any of them I get the error 800706BE.

The Microsoft help that appears gives several solutions:

  1. Fix It button. This downloads MicrosoftFixit50123.msi (963KB). After running it displays the message "This Microsoft Fix It has been processed".

  2. System Update Readiness Tool. This is actually in response to error 800B0100 which isn't the one I'm seeing. You download the file here (362 MB). After running it says "Do you want to install the following Windows software update: Hotfix for Windows (KB947821)"

I also found a command line fix here:

net stop wuauserv  
net stop Cryptsvc  
ren %windir%\SoftwareDistribution sdold.old  
ren %windir%\system32\catroot2 crt2old.old  
net start wuauserv  
net start Cryptsvc  

Update: I tried Moab's slightly longer command line fix (below) but that didn't work either.

4 Answers 4

0

Open an elevated Command prompt, type each of these commands one at a time, hit Enter key after each one, close cmd window when done, try Windows update again.

net stop wuauserv

rmdir %windir%\softwaredistribution /s /q

rmdir %windir%\system32\softwaredistribution /s /q

regsvr32 /s wuaueng.dll

regsvr32 /s wuaueng1.dll

regsvr32 /s atl.dll

regsvr32 /s wups.dll

regsvr32 /s wups2.dll

regsvr32 /s wuweb.dll

regsvr32 /s wucltui.dll

net start wuauserv

3
  • Step 1 - before any of this - is to clean any malware off the system. Oct 13, 2012 at 21:21
  • Tried it. The 18 updates I had waiting disappeared for a while but then later I had 26 queued. 2 worked but the other 24 failed with the same error.
    – parsley72
    Oct 14, 2012 at 3:45
  • Check for malware as suggested by Michael Hampton....superuser.com/questions/100360/…
    – Moab
    Oct 14, 2012 at 3:49
0

Couple things to check/try:

1) Ensure the RPC (Remote Procedure Call) Service is enabled (automatic) and running.

2) Destroy and rebuild your WMI repository. To that end, perhaps check out The WMI Diagnosis Utility from Microsoft.

2
  • 1. Yes. 2. "winmgmt /verifyrepository" returns "WMI repository is consistent".
    – parsley72
    Oct 14, 2012 at 21:02
  • Just because it's consistent doesn't mean it has everything properly registered. What did the WMI Diag Tool say? Oct 15, 2012 at 11:32
0

Reinstall the Windows Installer

Then run this commands to clear update list, restart services, and re register DLL files.

Open a command prompt with Admin rights: click on Start, type cmd, on the results right click on Command prompt, and select Run As an Administrator.

Try the following step by copying & paste following into the command prompt:

ipconfig /flushdns

Cd %windir% 

del /s *.chk;*.rip;*.tmp;~*.*

msiexec /regserver

sc config msiserver start= auto

net stop msiserver

msiexec /unreg

msiexec /regserver

regsvr32 msi.dll /s

regsvr32 msihnd.dll /s

net start msiserver

Regsvr32 wuaueng.dll /s

net stop wuauserv 

cd /d %windir%

rmdir /s /q  softwaredistribution

net start wuauserv

sc config eventlog start= auto obj= Localsystem

net start eventlog

regsvr32 qmgr.dll /s

regsvr32 qmgrprxy.dll /s

sc sdset bits D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)
(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)

regsvr32 wuaueng.dll /s

sc sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)
(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)

(A;;CCLCSWRPWPDTLOCRRC;;;PU)

sc config wuauserv start= auto obj= Localsystem

net stop wuauserv

sc config bits start= DEMAND obj= Localsystem

net stop bits

regsvr32 msxml.dll /s

regsvr32 msxml2.dll /s

regsvr32 msxml3.dll /s

regsvr32 msxml4.dll /s

regsvr32 qmgr.dll /s

regsvr32 qmgrprxy.dll /s

regsvr32 muweb.dll /s

regsvr32 winhttp.dll /s

regsvr32 wuapi.dll /s

regsvr32 wuaueng.dll /s

regsvr32 wuaueng1.dll /s

regsvr32 wucltui.dll /s

regsvr32 wups.dll /s

regsvr32 wups2.dll /s

regsvr32 wuweb.dll /s

net start wuauserv

net start bits

sc config cryptsvc start= auto

net stop cryptsvc

cd %windir%\system32\catroot2

del *.* /f/q/s

regsvr32 cryptdlg.dll /s

regsvr32 cryptui.dll /s

regsvr32 dssenh.dll /s

regsvr32 gpkcsp.dll /s

regsvr32 initpki.dll /s

regsvr32 mssip32.dll /s

regsvr32 sccbase.dll /s

regsvr32 softpub.dll /s

regsvr32 slbcsp.dll /s

regsvr32 rsaenh.dll /s

regsvr32 winhttp.dll /s

regsvr32 wintrust.dll /s

net start cryptsvc

cd\

sc config ose start= demand

net start ose

regsvr32 qmgr.dll /s

regsvr32 qmgrprxy.dll /s

regsvr32 es.dll /s

cls

Rem **************End of the process*****************

pause

exit
0

GRC's "Never 10" is designed to straighten-out the messy windows 7 updater, and then disable it's Windows 10 upgrade suggestions.

It was found that even after Microsoft turned off the "nagware", that Steve Gibson's program was still getting downloaded all the time - due to a happy co-incidence that it fixes the dreaded windows installer errors, as part of it's process.

I have run this app many times with 100% success to fix the 706be error, among others (searching for updates forever is another common one caused by the same thing). If you want Windows 10 later, you can still upgrade it - "Never 10" just disables the automatic pestering.

edit: sorry, to answer your direct question as to the cause, without going on a rant: it was caused by a patch to a file, and then a subsequent patch which had the older version of the file, and then the Cumulative-Update-Roundup (a group of several fixes in one patch, like a small service pack) which included both of the previous clashing "fixes". The same thing happened again in Windows 10, unfortunately, you PC was just one of the ones that got caught in the "perfect storm" .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.