10

When I clicked a mailto: link in a web page the following page appeared. How would I make it open in Gmail instead? I am using Windows 7.

enter image description here

9

If you are using the latest version of Chrome:

Go to Gmail, and you should see an icon in the address bar that looks like two overlapping diamonds (see the Chrome support link here). If you click the icon and select "Use Gmail," Gmail will be used to handle your mailto: links in the future.

If you do not see the two diamonds, you may need to double-check that handlers are enabled. You can enable them by going to Chrome settings --> Show advanced settings... --> Privacy section, Content settings... --> and look under handlers to make sure you have "Allow sites to ask to become default handlers for protocols" selected (see screenshot below).

Allow sites to become default handlers screenshot

  • This won't always show (e.g. if a previous user selected and then disabled this), so a more general solution would be better. – tog22 Jun 11 '14 at 7:35
  • This answer also works on OSX Mavericks, which is awesome for me :) – alengel Dec 3 '15 at 15:02
  • This didn't work for me. – samthebrand May 13 '16 at 12:37
  • This doesn't work as of 2019, with Windows 10 and Chrome 73.0. The icon with the two overlapping diamonds doesn't exist anymore, and the feature is not mentioned in the Chrome docs anymore. – LTR Apr 2 '19 at 9:04
2

Working as of April, 2019. Chrome 73.

Let Gmail handle Mailto links:

  1. Open Chrome -> Settings

    Chrome Settings

  2. Click Content settings under Privacy and security Content settings
  3. Click Handlers handlers
  4. Switch ON the Ask protocol Switch ON the Ask protocol
  5. Open Gmail in a new tab
  6. Click the Protocol Handler icon and allow Gmail to open all email links enter image description here
  7. Select Chrome as default email client

    Chrome default email client

Done!

Click on a mailto: link, Gmail will open a new email window.

@LTR - Thank you for reporting old answer was no longer working.

Credit source: How to Set Gmail as Your Browser's Default Email Client for Mailto Links

  • Thanks, your mailto fix worked! Although now new email windows open using my work email (google apps) instead of my personal email. Any chance you know how I might change default email address for mailto links? – samthebrand May 13 '16 at 12:36
  • @samthebrand, I'm glad it helped. Unfortunately, there isn't a way to 'subscribe' the link handler to an specific account. It will use whichever account you're logged in with on the default browser. You could use a separate browser and log in with the other account. Then simply set the default browser that you want links to be handled with. - Good luck! – Leo Gurdian May 14 '16 at 4:12
  • 1
    This doesn't work as of 2019, with Windows 10 and Chrome 73.0. – LTR Apr 2 '19 at 9:03
1

So based on your tags Google Chrome appears to be your web browser, go to the Google Webstore and download Send From Gmail (By Google) which will make GMail your default email application. https://chrome.google.com/webstore/detail/send-from-gmail-by-google/pgphcomnlaojlmmcjmiddhdapjpbgeoc

For Firefox users, go to Tools in the Menu Bar, then Options, the Applications tab, then look for the Mailto: and change the dropdown menu to "Use Gmail"

0

You can also search "file type" in the windows search box, and select change the file type associated with a file extension. Then scroll down to MAILTO. Double click on it and select chrome.

  • I think that is the "better start" since it works as well with email links embedded in word docs or PDFs. However it's only the first half of the solution: on my laptop it just switches to Chrome. What's next ? – Patrick Honorez Aug 15 '15 at 13:50
0

You can just create a link like the following and it will attempt to open Gmail and create a new message. You can specify "to" and "subject" and even the "message"

<a href="https://mail.google.com/mail/u/0/?view=cm&fs=1&to=toemail@email.com&su=hello world" target="_blank">
  • 1
    It will attempt to open Gmail is not an answer. Also OP is asking about mailto links which are on contact forms. – pun Dec 9 '15 at 23:33
0

I use Windows 7 and after sometime it stopped to work and handlers were not shown in Chrome settings (version 84.0).

In my case I used the next steps:

  1. Open in chrome://settings/handlers.
  2. Remove all data on this tab and disable handlers.
  3. Restart Chrome.
  4. Visit link from step #1.
  5. Enable handlers.
  6. Open tab with Gmail (diamond icon was shown in URL bar).
  7. Click on diamond icon and choose Allow.
-1

Gmail Notifier is a better solution for all browsers.

Here is answer from Google:

http://support.google.com/mail/bin/answer.py?hl=en&answer=10966

  • 1
    GMail Notifier is no longer supported. – Leo Gurdian Jun 12 '15 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy