8

Ok, so I inherited an excel workbook full of excel forms to modify. I am not the original author of the form. I cannot for the life of me figure out why it wont let me change the background color of certain cells.

The form has the cells colored where user input is required. I simply want to change this background color. I am using Excel 2007 on Windows XP, but this form was orginally created with an older version of excel.

Steps taken so far:

  • Worksheet is unlocked
  • Workbook is unlocked
  • cell is unlocked
  • any attempts to change the background color from (right click 'format cells' and ribbon controls). It looks like it changes it in the settings, but you say ok and it doesn't apply.
  • No VB code that affects the color of cells
  • Cannot not see any data validation that would even affect a cell color. (Maybe I am missing something?)

I do notice that once input is put the cell, the color of the cell will change to white. Is thier some data validation that can change cell color once content is inputed?

Any ideas?

4 Answers 4

18

Did you check for conditional formatting? It is harder to change.

Not sure where it is at in Excel 2007, but the mac version has it under:

Format => Conditional Formatting

Update: From the comments we have a way for Excel 2007:

Ah ha! I found a condition string for that cell. The condition formatting option is under the "Home" tab of the ribbon, not in data or formulas. – Troggy

1
  • Ah ha! I found a condition string for that cell. The condition formatting option is under the "Home" tab of the ribbon, not in data or formulas. Thank you.
    – Troggy
    Sep 29, 2009 at 22:09
1

ctrl +A to bring forward the "clear format options" icon (as shown in the image below) by double-clicking on format painter after selecting the whole sheet.

enter image description here

1

To work around this problem, turn off the high-contrast Accessibility Options. To do this:

  1. Click Start
  2. Click Control Panel.
  3. Click Accessibility Options.
  4. On the Display tab, click to clear the Use High Contrast check box.
  5. Click OK to close the Accessibility Options dialog box.

My Excel now lets me fill cells at will.

Note: Because there are several versions of Microsoft Windows, these steps may be different on your computer.

0

Here is a simple solution:

Select the cell, and just do Ctrl + \ (Clear Formatting)

or , you can select the cell , go to Format in the top menu, and then select Clear Formatting.

Thanks

1
  • Welcome to Super User! Clear Formatting is suggested in another answer, can you suggest anything else?
    – bertieb
    Jun 4, 2018 at 11:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .