65

Is there anyway to hide desktop.ini files, but unhide them when I need them? They get in the way when I'm moving files and such but I do use them so deleting them isn't an option.

6
  • 5
    Nope, I want to hide only desktop.ini files, all of the time. Not all files some of the time...
    – Oztaco
    Oct 14, 2012 at 20:31
  • 1
    Why not just turn "Hide protected operating system files" (back) on in Explorer's folder options? Or is the goal to show all hidden/system files except desktop.ini specifically? What have you tried already? It'd probably be easier to just rig up a system-wide toggle for ALL hidden/system files and just use it as needed, vs. trying to hide files with a specific filename. Oct 14, 2012 at 20:37
  • Yeah, seems he has show hidden checked and hide protected unchecked, maybe by mistake.
    – Karan
    Oct 14, 2012 at 20:39
  • 1
    @techie007 yes I want to hide nothing, except desktop.ini. I can't delete them because I use a script to edit the desktop.ini files that changes the icons occasionally so that would get in the way of my script.
    – Oztaco
    Oct 14, 2012 at 20:44
  • 1
    So basically, this question is asking how to hide an arbitrary file by filename. I have seen some shell-extensions that could potentially be adapted for this purpose, but that was in XP; I don’t know if they could work in Vista+ since Explorer has changed too much and been locked down a lot.
    – Synetech
    Dec 7, 2013 at 17:23

7 Answers 7

46

Found a better answer on technet:

Simple: click the "hide" box only in Desktop folder

(In Windows Classic view,) go to Windows Explorer; click on Desktop. Go to Tools/Folder Options. Click View, and check "Hide protected operating system files" - but, DO NOT CLICK "APPLY TO ALL FOLDERS". Just click OK. Now, only the Desktop folder will hide the files but they will still show up in all other folders.

7
  • 3
    Thank you, this is so blatantly obvious and brilliant at the same time!
    – Oztaco
    Jun 26, 2014 at 0:51
  • 25
    I did it (in Windows 8), but it applied to all folders. Jul 15, 2014 at 5:15
  • 15
    Looks like Windows 10 View > Hidden Items is also applied to all folders. Feb 23, 2016 at 21:26
  • 11
    This does not work for me. When I do this, it always seems to change for any other folder, too! Even though I change the folder template on the non-desktop folder, the settings still seems to apply!
    – sandos
    Oct 21, 2016 at 13:15
  • 1
    Same for Windows 10. This option is applied globally to all folders. :(
    – Avatar
    Jun 4, 2020 at 8:59
16

Desktop.ini files by default have the System and Hidden attributes set. If you have Show hidden files, folders, and drives turned on, make sure Hide protected operating system files is checked under Windows Explorer's Folder Options / View tab:

enter image description here

4
  • 1
    If I'm not mistaken, this will hide system folders too?
    – Oztaco
    Oct 14, 2012 at 20:41
  • Most OS folders (Windows, its subfolders, Program Files etc.) are visible to me with this option checked (and Show hidden unchecked).
    – Karan
    Oct 14, 2012 at 20:50
  • 1
    make sure Hide protected operating system files is checked under Windows Explorer's Folder Options / View tab This applies only to Windows 7. In Windows XP, the hide system files option has no bearing on files with the system attribute; it only hides the contents of \windows\*. Since the OP has accepted this answer, it can be assumed that they are using Vista+, not XP. For anyone using XP, the hide hidden files option should be sufficient for toggling the visibility of files with either the hidden or system attribute.
    – Synetech
    Mar 1, 2013 at 21:27
  • That's not an option for me (I need to be able to view system32, etc.) -- Might help others though. Sep 11, 2020 at 21:04
3

I once used command prompt to hide some files and folders by changing the attributes.

Suppose you want to hide the file “desktop.ini” which is in your X: drive(can be redirected to any location). So open command prompt typing “cmd” in the “run” from Windows start menu.Now change the drive typing “ X: ” and then press enter.

Now enter the following command:

X:> attrib desktop.ini +s +h

(for hiding file/folder filename, replace 'desktop.ini' by filename)

Now desktop.ini would not show even if you display all hidden files in windows explorer.

To revert the process, following command needs to be used:

X:> attrib desktop.ini -s -h

This works fine in Windows XP, Vista, 7.

Resources:- [1] http://www.techtipsgeek.com/hide-files-folders-command-prompt-windows-xp/1001/

3
  • 4
    Check your system. As I mentioned above, Desktop.ini files by default seem to have the System and Hidden attributes set already.
    – Karan
    Oct 19, 2012 at 17:05
  • checked it, you were true.
    – Mohit
    Oct 20, 2012 at 15:25
  • Don't forget the /s switch for going in sub folders Jul 15, 2013 at 1:20
0

How to get out of the way any icon in Windows

Believe it or not, all you need to do is turn off "Align to the grid".

Once you have done it:

  1. Put the two desktop.ini icons one near of the other.

  2. Select both icons using your favorite method (selecting around, using Ctrl-Left Click, check boxes or whatever).

  3. Grab the selection using a point from the leftmost part and... drag it to the right off the screen!

  4. Release the selection.

Keep in mind that this will only work while you keep "Align to the grid" option off. If you need to tidy up your icons to the grid, you can always turn it on (the icons will reappear), turn it off again and repeat the four steps above.

You can do it this quickly without third-party tools, any command line or messing with the registry. The only tricky part (not much I think) is grabbing the selection the "leftest" possible, which may need two or three tries. Nevertheless, there are ways to assure this. For example: align the two icons to the grid on the left border, switch off the alignment, select both and put the pointer all you can to the left at the same height of the selection. Now you are at the leftmost part of it so you can grab it and sweep it out without trying.

The funny part of this is that you can have icons on you desktop that nobody will notice looking at it (or even using it) but can be accessed if you know where they are. You can, for example put an icon at the right of the desktop, at the same height of your secret icon. If you select the former and press , you select the latter. Pressing Enter will launch it. Another way is writing the name of the shortcut after selecting any desktop icon (provided the beginning of the name is distinctive).

3
  • 1
    Tried this, and worked partially for me (maybe is because I have scaling > 100%). The user's Desktop.ini, for some reason, can't be dragged out of the desktop, only the public one can. Sad
    – edmundo096
    Jan 4, 2019 at 8:41
  • 1
    Nope. Windows 10, and these desktop.ini files keep jumping around to weird places and messing up my other icon positions even if I drag them normally. And then we're not even talking about the mess they cause when plugging in my second monitor.
    – Nyerguds
    Feb 25, 2020 at 7:49
  • Yeah, the files just come back and bounce all over the place. Sep 11, 2020 at 21:07
0

To hide desktop.ini files but leave all other system/hidden files visible just save desktop.ini in CP1200 UTF-16 Little endian. I stuck with that problem a few times before and found that way.

Here's what you need to do to achieve that:

  1. First of all, you need to open your current desktop.ini with the editor that can edit in UTF8 and UTF-16LE encoding pages. I've personally use Far manager.
  2. After opening a file copy (cut) contents of desktop.ini to the buffer.
  3. Now you must have blank desktop.ini in possibly UTF-8 encoding (no matter) and a content in the buffer.

Or you can create blank desktop.ini in UTF-16LE codepage by running this commands in command line (it will create file in directory where you run commands):

CHCP 1252 >NUL
CMD.EXE /D /A /C (SET/P=ÿþ)<NUL > desktop.ini 2>NUL
  1. Change encoding of desktop.ini to UTF-16LE (in Far manager you must press Shift-F8 and select "1200 UTF-16 (Little endian)" codepage).
  2. Insert contents of buffer (Shift-Ins or Ctrl-V in Far manager)
  3. Save desktop.ini (Far manager can warn you about possibly losing some symbols - ignore it and just save).
  4. Done. Now desktop.ini saved in UTF-16LE codepage and it will be ignored by Windows no matter enabled or disabled "show system/hidden files" option.

It's a permanent result and will not break if you reset Folder view options in Explorer as mentioned in Jens Erat answer.

3
-1

The easiest way is with Nirsoft's BulkFileChanger. I also used Voidtools Everything to search for:

attrib:h c:/

I dragged the results into BulkFileChanger and then changed them all to unhidden [F6] or [Actions menu]>>[Change Time / Attributes.]

  • Note: some objects will not change. Access is denied. Don't worry about it. (A few will change if you select them one-at-a-time, but it's not worth it. Though I did change my Library junctions, like Videos and Pictures, this way.)

Afterwards I searched in Everything again (make sure you use a bar | in between to specify OR):

desktop.ini|thumbs.db|ehthumbs.db

Drag and drop them all into BulkFileChanger and change them to Hidden the same way [F6]. Do this again for anything else you want hidden.

  • ****Note: Run both programs above AS ADMIN (elevated.)**
1
  • 2
    desktop.ini is always set hidden. The point is that even when you want to set all hidden and system files visible on your system, you still don't want those irritating unremovable ones floating around on your desktop.
    – Nyerguds
    Feb 25, 2020 at 7:51
-3

to solve that issue goto local disk C then search for (desktop.ini) then when the search is done press (Ctrl+A) to select all the file of desktop.ini then select view on the top or press (Alt) then navigate to view then select (Hide selected items). You are now done

Not the answer you're looking for? Browse other questions tagged or ask your own question.