I have a 1TB Western Digital hard drive which is almost full and last time I tried to plug it into my laptop, I got a Windows dialog saying "this hard drive needs to be formatted". I did not panic because I have experienced things like this before and I know it's often solved by simply re-inserting the drive.

Now however, whenever I plug it in and try to browse it in explorer by going to "computer", the explorer process crashes after a while. I simply close explorer since it takes ages trying to read the disk and nothing happens.

After searching on the internet, the best thing to do would be a chkdsk. I tried it via properties in explorer (which also took a good 5 minutes to open up), locks up as well, after waiting a couple of minutes it says there's no access to the disk so a chkdsk is not possible...

I want to make clear that I always use safe removal before pulling out the USB cable. Last time however, safe removal just would not work and when trying to shut down Windows, the logoff screen just would not disappear (I've waited at least 10 minutes or so) and I powered off the PC by force. This may be the cause of the problems but the disk was still recognised immediately after that.

I really don't want to format this thing because it contains C: clones of 3 computers and a lot of other stuff that I don't want to re-copy. What would be the best course of action?


I got chkdsk working via the command line. I used the /F and /R options. I already got a bunch of lines saying "file record segment X is unreadable" or whatever it is in English, my OS is Dutch. It looks bad... Will chdsk repair these errors?

Update 2

I have a CentOS 6 VM and when trying to mount the disk there, it says "invalid filesystem type ntfs". The Disk utility warns me of imminent disk failure. There are over 800 bad secotrs. I tried e2fsck on it but it says the superblock is bad. Then I did dumpe2fs to find backup superblocks but the command fails with a message about a bad magick number in the superblock.

How the hell does this happen to me while yesterday everything was perfectly fine...

  • 1
    One of two things, the usb controller inside the enclosure is failing or the hard drive is, remove the hard drive from the enclosure and connect it using a different hard drive to usb adapter, see if you can read the data on the drive. – Moab Oct 15 '12 at 15:00
  • @Moab would there be any other solution? – MarioDS Oct 15 '12 at 15:26
  • There are plenty of other things that could be wrong, but @Moab's is a fairly simple way to eliminate one big potential cause of trouble. – Zac B Oct 15 '12 at 16:38
  • @MarioDeSchaepmeester always is, but I suggest the safest solutions first, besides what is the data worth..... – Moab Oct 15 '12 at 18:51

Hold up. Seriously, stop for a moment.

It sounds like you're running potentially destructive Linux-specific filesystem repair utilities (e.g. e2fsck) willy-nilly on a Windows hard drive. Even if there wasn't something wrong before, this could make it worse.

Before you do anything else, I highly recommend taking the drive out of the enclosure, connecting it to a lightweight, natively-booted (no VM layer) Linux environment (Puppy is my favorite), and using dd or similar to take a full-image backup of everything readable on the drive--either to a file on a known-good drive (preferable), or straight across to a same- or larger-sized drive with the same interface (i.e. SATA). Get a frozen copy of the data somewhere you know it won't get further corrupted by using incompatible repair utilities on it/performing intensive operations on a failing drives.

Once you've done that, put the image on a known good hard drive (but seriously; keep a copy of the image somewhere that you know it won't be altered. If this data is important, it's worth buying/loaning a big HD to store on). Load the known-good hard drive up, connected to a Windows environment, and try to run CHKDSK on it. It sounds like there is a lot of corruption, but I've often seen repairs work very well on bad-sector filled drives once the readable data was cloned to a working drive.

  • Thanks for your answer but I have concluded that the hard drive is unsavable. The data can still be read with a data recovery tool I'm running now. I just bought another HDD (the same to be precice) and I'm moving all readable data to it. The disk itself seems beyond repair as chkdsk etc did nothing. – MarioDS Oct 15 '12 at 17:39

Right click on computer and choose manage. Then on the left hand side of the manage window go to disk managment. For the external drive is it listed as a usable drive or does it list as unallocated? If a window comes up when you go to disk managment asking about MBR click cancel or you will begin formatting the drive.

  • It does come up as a usable drive. It's just not readable anymore somehow. – MarioDS Oct 15 '12 at 15:30
  • Try using the drive on another computer to see if you can replicate the error. – PlanOfAction Oct 15 '12 at 15:53
  • I just tried to mount it in a CentOS VM. It says "disk failure imminent" and reports 892 bad sectors. WTF... – MarioDS Oct 15 '12 at 15:55
  • 1
    It sounds like something on the drive is corrupt. check disk should be able to fix the error without removing any data. I beleive that is your best bet. – PlanOfAction Oct 15 '12 at 16:00
  • I have done a chkdsk to no avail – MarioDS Oct 15 '12 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.