I'm having a strange problem on two of my home 64-bit Windows 7 machines. About 75% of the time when I boot from a cold start, my profile fails to load. The event viewer gives me this error:

Windows was unable to load the registry. This problem is often caused by insufficient memory or insufficient security rights.

DETAIL - The process cannot access the file because it is being used by another process. for C:\Users\Roger\ntuser.dat

If I log off and back on, the profile always loads correctly.

Does anyone have any ideas? I'm not sure what other than Windows could grab my profile upon boot. I've checked permissions of the ntuser.dat file and system has full control.

  • Was this profile migrated from a windows XP or Vista machine? – A Dwarf Sep 30 '09 at 0:53
  • No, they were both clean rebuilds. – Roger Sep 30 '09 at 2:56

Have you tried creating a new account and check if the problem occurs there as well?

I've seen a post on TechNet where they suggest it as a possible solution.

An accepted solution there was Startup Repair:

If the issue persists, you can also perform Startup Repair. Since you are now logging on in Windows Vista Operating System, you need to use Windows Vista installation disc. To do this, please take the following steps. Note: Please ensure that the DVD-ROM is the first booting device.

  • Please insert the Windows Vista DVD and reboot the computer.
  • When we are prompted to press a key to boot from the DVD, please press Enter or the space bar.
  • Choose your language settings, and then click Next.
  • Click Repair your computer.
  • Select the operating system you want to repair, and then click Next.
  • On the System Recovery Options menu, click Startup Repair. Startup Repair might prompt you to make choices as it tries to fix the problem, and if necessary, it might restart your computer as it makes repairs.

Another suggestion they made there makes you lave the trouble making files behind (note this was under XP I think):

You need to create another profile for each user, with all the same attributes and privilidges for that user, then go into an admin account (not the account that your changing or the account that your setting up, a different one) then in folder options make sure that "show hidden files and folders" is checked, and "hide protected operating system files" is unchecked. then go to the "C:\Documents and Settings\Old_Username folder" Press and hold down the CTRL key while you click each file and subfolder in this folder, EXCEPT the following files: Ntuser.dat, Ntuser.dat.log, Ntuser.ini. right click and choose copy, go to the C:\Documents and Settings\New_Username folder and right click and choose paste. reboot the computer and then you should be able to log on as the new user

  • Thanks for the tips. I'm hoping not to have to recreate the profiles; since it's happening to two different users on two different machines, I'm leaning more toward a Win7 issue than the standard profile corruption problem, but I'll give Startup Repair a try. – Roger Sep 30 '09 at 12:11

I noticed this with XP computers in my line of work quite a few times. It stems from Windows not unloading the registry hives quick enough during shutdown. It's similar to pulling the network cable out while you have a file open on a server and when you restart and reconnect, the server thinks another you still has the file open.

The UPHClean tool always did the job pre-Windows 7 but does not work out-of-the-box with Windows 7. The URL gives you background information on the problem which is similar to your sitation with access denied errors.

You can now download and install a beta of version 2.0 of the User Profile Helper Cleanup Service (bit of a mouthful) instead which is compatible with Windows 7. I can confirm it works under Windows 7 quite happily.

EDIT - as you have stated that you have 64-bit Windows 7, try this link instead which points to the 64-bit flavour.

  • Thanks, but this doesn't appear to work on the 64 bit OS, which I'm running. :( – Roger Sep 30 '09 at 12:14
  • Updated my answer with a link to the 64-bit version. – Kez Sep 30 '09 at 16:21
  • 1
    No go... I get a message saying "UPHclean is supported only on Windows XP through Windows Server 2003". I should have mentioned that earlier - sorry. – Roger Oct 2 '09 at 12:02

when booting if you just wait 15 seconds before you type in password you should always get in. I have 2 windows 7 installations doing the exact same problem. Hope microsoft will fix it soon.


I found my issue. It is related to Media Center, which I'm running on both machines. If I shut down while Media Center is recording, it appears that the profile isn't properly closed. I've solved the problem by cancelling any recordings manually 15 seconds or so before shutting down.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.