Around a week ago I sometimes had trouble bringing up Windows XP profile (so it would boot into a temporary profile directory). I ran CHKDSK three days ago on boot and didn't find any bad blocks.

Starting yesterday, my desktop (Windows XP SP3) became really weird. After I booted up it seems like something was eating up my CPU (though I didn't see anything suspecting in the resource monitor fired up using Ctrl + Alt + Delete). The computer booted very slowly, and applications started very slowly. My real video files which used to play smoothly was lagging. My phone dial up had trouble logging into most web sites while some (like Slashdot and google) seemed to be more or less fine.

Was there problem with the network? My girlfriend's netbook running behind a home gateway (which dialed pppoe for her) connect to the web just fine! So this ruled out the possibility.

Today I booted up again, and the same thing happened. At first I suspected it was a virus. So I changed my BIOS settings to boot up on another physical disk (the OS wasn't MS Windows). Something was very weird, it still had the same network connectivity issues. I scanned my Windows C partition. Clam AntiVirus claimed that there was this executable resting on my Windows desktop directory containing a trojan whose name I cannot recall now. I tried to go into the directory to check the file, but I suddenly couldn't get in. So I rebooted the computer and tried to switch back to Windows only to find out I cannot boot!! It says "a disk read error occurred" and ask me to press Ctrl + Alt + Del to restart.

I wasn't suspecting a disk error! The disk is relatively new (two years and four months). I ran CHKDSK at boot around three days ago. The event log told me I have 0 bad block! So I am now in shock that suddenly I can no longer boot, nor mounting the disk from the other OS. I tried to unplug the SATA cables and replug it to no avail.

So here are my questions!

  1. I don't know why the network connectivity is weird as it is. If it is the trouble with Windows or the hard disk, then this other OS on the other disk should run just fine. But it turns out that it runs fast, but network is still a problem.

  2. Given that there probably isn't any bad block in this disk (right?? I hope), and I desperate need the data in there and I have no back up, is there a good chance that I can bring it to some shop to recover my data?

  3. Could there also be other possibilities that problem is not related to virus or disk? Such as a motherboard problem?

  4. What can I do myself to recover the data?

  • Interesingly, I removed the disk, and this other OS has no Internet issue now.
    – huggie
    Sep 30, 2009 at 5:32

3 Answers 3


The utility SpinRite contains unique technology that can resuscitate bad hard disk sectors. It costs $89 but comes with Satisfaction Guaranteed refund. I've personally used it to save hard disks that subsequently worked for years afterward. From the web page:

SpinRite v6.0 recognizes and operates on ALL file systems. It can even be used to repair and recover Apple Macintosh and Tivo hard drives by temporarily moving them into an Intel-based PC. It can also be used to check the health of drives that have not yet been formatted.

  • Out of desperation I've just sent it to the specialist. But my questions on this post still remain. Does this tool work when I can't mount the drive? (BIOS detects it, but no mounting)
    – huggie
    Sep 30, 2009 at 6:57
  • +1 as long as the BIOS recognises it, SpinRite has a decent chance of working its magic.
    – Kez
    Sep 30, 2009 at 7:16

Given that your virus scanner found a suspectible file and the sudden occurence of your problems, I assume it's a virus

Try booting the computer into save mode and move all the files to a backup/alternative drive. Make sure to scan the files for viruses later on, though I might be paranoid suggesting it.

Then simply reinstall the OS. If you want to backup your settings, use EasyTransfer. Other things to prepare reinstalling are the most important drivers and applications you want, but if you have to download them: use the alternative OS or your GF's netbook.

Have a look at this question if you need more tips on cleaning up an infected computer.

  • I can't. There is no safe mode to choose from. "A disk read error has occurred" pops up before I can boot from the MBR. I can't mount it on other OS either.
    – huggie
    Sep 30, 2009 at 6:55
  • 1
    Boy you're screwed...
    – Ivo Flipse
    Sep 30, 2009 at 7:08

Your disk symptoms could be explained by a lack of power to the disk - broken power cable, broken PSU, or perhaps a bad motor in the drive itself. Does it spin up?

That the other OS runs better without the first disk attached is interesting, perhaps your mobo has a bad sata port.

I would suggest connecting the drive to a different computer altogether, to eliminate all potential error sources except the disk. You already made a comment that you sent it to a specialist, so - good luck...

  • 1
    Lack of power....that's a possibility. I only have 300 watt and I did add a new video card lately (Nvidia 9600 MD 1G, requires no extra cable for power). Initially my OS would shut down without apparent reason. After I noticed CPU temp was shooting up, I clean out the dust on the CPU heat sink and there is no problem since... Except when I do log on via remote desktop connection sometimes comp seem to shutdown. Though this is a long time problem (b4 I added the video card).
    – huggie
    Sep 30, 2009 at 10:01
  • But that problem do occur more often lately. So I don't know. I'd always suspect it's a software problem, since it only seem to shutdown when I attempted remote logging. (It would let me login once and then freeze, subsequent attempt will not connect, ping unreachable, screen black) I thought it might has to do with the theme I modded. Can lacking in power result in hardware defect in anyway? The hard drive was spinning by the way. I took out the other disk, and simply put the problem-ridden one in. I still couldn't boot.
    – huggie
    Sep 30, 2009 at 10:05
  • I have AMD X64 4000+ brisbane, One DVD RW, two to three drives (depends), one floppy, 2G RAM, Nvidia 9600 MD 1G. That's it.
    – huggie
    Sep 30, 2009 at 10:09
  • Lack of power can cause all of these problems. So can a failing power supply or loose connections on Power Supply connectors. Assuming the P/S is working OK, even if it is rated for enough watts of power, you have to consider if the Watts are in the right place- older systems need more 3.3V power, newer more 12V power, your P/S may have too much of one and not enough of the other.
    – kmarsh
    Sep 30, 2009 at 12:42
  • Thanks, your comment is very informational. I think I'll go shop for a new PS. :)
    – huggie
    Oct 1, 2009 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.