I'm a developer and as part of the build process, a Microsoft dll is copied to a certain folder. That file copy is now failing as the target can't be overwritten.

I decided to delete it by hand (using an admin account but a non-elevated explorer) so browsed to the folder and attempted a delete. This failed (Require permission from the Administrator). The same applies when using an elevated explorer.

So I tried Properties->Security->Advanced->Ownership

The current owner is showing as Unable to display current owner. I can't take ownership (a simple Access Denied message with no elaboration). Elevated Command Prompt/PowerShell don't help either (both give an Access Denied in their own way).

Process explorer shows no open handles on the file.

Eventually, I booted to linux and deleted the file but what I'd like to know is what caused it?

Security Essentials had no issues with the file. It's digitally signed by MS and the signatures match.

  • possible duplicate of File I can't take ownership of
    – CharlieRB
    Oct 16, 2012 at 14:12
  • @CharlieRB I've read it - but as you can see, my problem isn't removing the file but understanding what the "loss of ownership" is caused by.
    – Basic
    Oct 16, 2012 at 14:23
  • You are right. Sorry. Guess I got lost in reading it and misunderstood the question.
    – CharlieRB
    Oct 16, 2012 at 14:35
  • In some cases, deleting a file needs to be done externally, e.g. Safe Mode, or as you did booting into another OS. If the file has certain attributes (I'm not exactly sure but I think System affects it), along with the existing SYSTEM permissions, that makes it untouchable in the context of the booted Windows. Obviously once you go away from that context, it becomes irrelevant, but inside Windows 7 (and 8) some files are certainly undeletable.
    – user3463
    Oct 16, 2012 at 16:05
  • @RandolphWest Thanks for the answer. Can you explain a little more? I know anything with an open handle can't be modified but suspect that if I deleted everything I could in my windows dir then rebooted, I'd have bricked my machine - so there's no "required for windows" flag set on a lot of files. Pagefile/etc come under the heading of open handles. I just don't see how a DLL buried in a folder on my D drive which has been replaced every few hours for days can suddenly be flagged as undeletable (nor what that "flag" is?)
    – Basic
    Oct 16, 2012 at 16:39

6 Answers 6


I had this issue too for a file I manage with SourceTree ( git client ). This file had no 'Owner'. I just noticed that closing down all application susceptible to use it, removed it magically. The other option was to remove the file in windows' safe-mode. I don't know why this happened though and I'm curious too as to why this happened.

  • 3
    This happened to me too, which is what brought me to this question. A git checkout created a folder, then afterwards I couldn't do anything with it (and couldn't checkout anything else that would modify it!). Your comment helped me realise I had other git bash windows open; once I closed them all the folder magically deleted :)
    – Tim Malone
    Apr 26, 2016 at 0:50
  • Thank you!! Also note that even if all git bash windows have been closed, there may still be a stray bash.exe process which was the culprit in my case.
    – Jimmy He
    May 26, 2020 at 18:27

One solution works for me on Windows 7 :

Right click the hard disk drive, ==> Properties / Tools / Check now .... And then try to delete again, it should work.

  • Warning: You have to reboot and the reboot may take several hours.
    – User
    Dec 8, 2016 at 20:53
  • Update: After several hours, it did fix the problem.
    – User
    Dec 9, 2016 at 19:05
  • NB: It's quite possible the reboot alone would fix the problem [If it were an orphaned handle to a deleted file]. Try that first, it's a lot faster.
    – Basic
    May 26, 2020 at 18:43

In my case it was a file I'd used Firefox to download. Couldn't display owner, change ownership or delete the file (though it was readable). Using lockhunter to delete the firefox lock on the file worked.


I found that a folder with "Unable to display current owner" was locked as a library location (such as Music Library). I removed that as a Location and I could delete folder.

  • That's one hell of a gotcha, I would never have thought of that. Thanks. It wasn't the issue here, but it will definitely help others in future with the same symptoms.
    – Basic
    Oct 30, 2016 at 21:33

I had the same issue with some files in the windows directory, most likely caused by a virus.

running sfc /scannow fixed the problem for me


Open command prompt with admin rights, then type:

net user administrator - this will display current settings.

Use net user administrator /active:yes to activate if needed.

This is the built-in administrator account for managing the system. It is usually not active.

  • 1
    Thanks for the tip but if it was owned by the local admin account, 1) wouldn't another admin be able to take ownership and 2) wouldn't the security dialog have identified the owner? It was my understanding that only the SYSTEM account had higher permissions than a user in the administrator group
    – Basic
    Oct 16, 2012 at 14:27
  • 1
    Your understanding is correct, @Basic.
    – user3463
    Oct 16, 2012 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.