Every once in a while, when I start Synergy on Windows, I get this message:

failed to init synrgyhk.dll, another program may be using it

How can I resolve this? The only workaround I've found is to restart the computer, but is there a better fix?

  1. Download Process Explorer
  2. Run it, and search for synergy by clicking on the little binoculars
  3. Kill all processes using the troubling dll (synrgyhk.dll) - be careful here to not kill anything important
  4. I had to kill a process called splwow64.exe that had a handle on that dll for some reason, and everything worked great after
  • Another note, I was experiencing problems after a while again, but realized the batteries in my mouse were dying this time! – capcom Oct 28 '12 at 1:40
  • 4
    You can also try stopping/starting service in Services, and reset your settings (it's in Regedit, search for it.) With all these three, I managed to fix some weird issue... (no specific error, it just died on me.) – Apache May 19 '13 at 11:34
  • 1
    In my case it was google chrome... – Vlad Spreys Oct 17 '13 at 1:16
  • Was google chrome here too...strange – patchie Feb 20 '15 at 12:49
  • Had this occur on both my servers today. The first (Vista machine) I just uninstalled the program restarted and that fixed it. On my current machine (also Vista) I had to do as described here, and found dmw.exe to be the culprit (as well as iTunesHelper, and a bunch of other seemingly unrelated programs. Thanks. – gollumullog May 27 '15 at 22:53

I couldn't find a solution from the synergy Q&A's site, but I found it here. Run services.msc and restart Synergy service. It should allow you to start the server now. Thanks Shiki for the suggestion. I, however, didn't need to reset the configuration in the registry. I'm thankful for that since my password is 30 digits and I don't remember it.


Option A

  1. Go to Run, type services.msc
  2. Stop the Synergy service and start it again.
  3. Start Synergy app and voila! No need to restart PC.

Option B (on windows 8.1)

  1. Open task manager
  2. Go to Services
  3. Stop the Synergy service and start it again.
  • 2
    Thank you for your answer. Can you provide any more context around why your answer fits the question? Why OP might be getting the messages? – CallumDA Apr 2 '15 at 14:34
  • @CallumDA33, different versions of Synergy behave differently. Here's one useful thread in product support db, someone says, "several processes should be able to access the same dll. and they do so.. but sometimes Synergy Pro 1.7.4 (latest build) is troubling it.", and the best suggested solution is "Usually, the simplest way to fix that is to restart the Windows synergy service". I doubt anybody can tell more than this. – bytebuster Oct 20 '15 at 11:19

Just download: Unlocker, and navigate to the installation folder of Synergy. Right click the synrghyk.dll, choose Unlocker and kill all processes with it. Then it should work fine.


Happened on my Windows 7 64-bit Synergy Server today...

Possible trigger... the whole machine hiccuped briefly as I tried to access an external drive that had gone to sleep. When the machine resumed, Synergy did not.


  • In Windows Task Manager I brought up "Processes, All users" and killed anything with "Synergy" in the name.
  • I then went to "Services" and did a "Start" on the Synergy service.
  • Then I restarted Synergy (the app) and it worked.

The order is important, because I tried to do those steps in different orders and it didn't work because the Synergy process keeps the Synergy Service from shutting down, etc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.