I'm running Photoshop CS4 on WinXP and I have been sent a PSD as well as the needed fonts. I have installed all the fonts I got into the Windows fonts directory.

When I open up the PSD in photoshop it tells me I am missing some fonts, then when I go to click on some text it tells me you are missing Roboto Bold or Roboto Regular.

I then go to the windows fonts dir to confirm all the fonts are there and they are.

See below..

enter image description here

It seems the font list in PS shows most of the above fonts, but not all, and conveniently the ones that the PSD uses are included in the ones that aren't loading.

The ones that aren't loaded are:

Bold Italic
Condensed Italic
Italic (Regular Italic)

Well, of all the things I tried the only thing that worked for me was to put all the fonts (.ttf files) in the following folder:

C:\Program Files\Common Files\Adobe\Fonts

I didn't have this folder, so you may need to create it.

Hope this helps others!

  • 1
    This solved my issue too. When I downloaded the Robot font archive from the Android Design Guidelines and installed them, all fonts worked properly except Roboto Regular. Placing all fonts in the aforementioned folder fixed this issue. – Ryan R May 16 '14 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.