I have some (I'm not sure exactly what model) Lenovo 21" IdeaCentre. Honestly, the computer works off and on. I have had problems with it not being able to shutdown, which I fixed. The fan seems to be constantly running, a few other problems as well. Anyway, nobody was using it when all of a sudden it switched to a blue screen. I was in the kitchen, but when I got over to the computer I read the message. It said something about bad drivers, but that is all I saw and then it restarted.

However, when it got to the Lenovo Splash screen, nothing happened. I waited there for over 10 minutes, but still nothing. I tried to turn of the computer, but the only way to do it was to pull out the power cable. I then removed all USB devices and tried again. Still nothing. It also won't respond to keyboard input when I try to use enter to interrupt normal startup.

My guess is some piece of hardware is damaged inside the machine. However, I have no idea what piece it is. Does anybody have any idea what could be wrong with it?

  • Had you done anything else to the machine prior to this problem? Such as driver updates, bios updates, etc...?
    – C-dizzle
    Oct 18, 2012 at 17:25
  • No. Everything seemed to be working fine, besides the fan. I kind have been waiting for the hardware to fail though. Anyway, I don't believe anyone has done anything to it all day. definitely not anything significant such as driver updates, bios updates, or anything similar.
    – Josiah
    Oct 18, 2012 at 17:27
  • Start with removing everything that is not needed. Flash drive plugged in? Remove it. External hard drive? Rip that out. bluetooth, wifi, or other USB adapters? Same deal, pull them out. Next step is to look at your memory config. 1 piece of memory? Might be bad, but youd need another one that is known good to check that. Start by pulling the hdd, and 1 stick of memory if you can. At least we need to get it past the splash screen. Once there, we can begin to run tools like Memtest and Drive Fitness Test.
    – user76211
    Oct 18, 2012 at 17:36
  • I'm not real familiar with those kind of machines, but this is what I would try; open the machine, remove each piece of RAM one by one and attempt to power on. If you get past the splash screen then, it's faulty RAM. If that doesn't work, try removing the CMOS battery for about 15 minutes, replace then try again. If that doesn't work, it might be a bad hard drive. Do you have any others to swap in there and try booting up? Just a couple quick things I would try...
    – C-dizzle
    Oct 18, 2012 at 17:37
  • Not at the moment. If I remove the RAM, but not replace it, will I still be able to get past the Splash Screen?
    – Josiah
    Oct 18, 2012 at 17:46

3 Answers 3


Visual inspection:

  1. First remove mains from power supply and after that press power button once.
  2. Remove covers.
  3. Check if there is a dust in radiators or fans. Clean with compressed air if needed.
  4. Take visual inspection, focus on capasitors at motherboard and check if any of them is broken / leaking / blown. Here is another answer with picture.
  5. Check that all radiators are firmly attached in place.

Results and going forward:

Visual inspection: Dust it is possible that components under clogged radiators may have been overheated and possibly broken. Testing single components is not so straightforward and requires either known good components around them or special testing equipment.
Visual inspection: Capasitors If you have problems with motherboard capasitors you should replace your motherboard, you can also attempt to replace capasitors with new ones (make sure they have same ratings).

After visual inspection comes basic testing:

Find out if it works as expected with minimal system configuration.

To perform this basic test you should disconnect everything that is not essential for booting up operating system. Basically this means disconnecting hard drives, optical drives, front panel USB/other connectors, any add-in cards and all but single RAM modules.

After you have done this try to power up your computer, it should load BIOS and complain about "Operating System not found". If it still hangs, swap memory modules still leaving only one module in and retry booting. You could also try selecting different memory bank, not first one.

If this does not take you any further then you should try to reset BIOS. There could be switch or button for that labeled "CMOS reset" or something similar. Another way to reset BIOS is to take off battery that is located somewhere in motherboard and pushing power button for 30 seconds without mains connected.

After that, try to power up computer again with minimal system configuration.

Results and going forward:

Boot process goes further: this basically means that you have removed faulty component, this raises up quoestion about which one it is? Start by connecting hard drive again and after that try to boot up. If it works, take all other components but RAM, put them back and try to boot up. If it still works connect everything, try to boot up. If it hangs remove RAMs, download memtest86 and test all RAM modules with it, one by one. You can also test your hard disk with SeaGate Seatools (drive can be from any mfg).
Still hangs at same point: Notify about it here at comments and we can try to make some deeper inspection.

  • Alright, I got nothing to lose. I'll try that.
    – Josiah
    Oct 18, 2012 at 17:47
  • Okay, I looked up the issue on Lenovo's website and it does appear to be a BIOS issue. I have to go do something, so I will try to tackle it tonight. I'll update my question then.
    – Josiah
    Oct 18, 2012 at 17:56
  • Alright. It works fine now... Now is the keyword though.
    – Josiah
    Oct 18, 2012 at 21:06

My T400 stuck at the splash screen just like that from one day to another, after a trip. The problem was a broken USB port, which had one of its connectors in short with the port's shield. After the removal of the shortage, works as before. Hope it helps.

  • You sure that wasn't the ground pin? :-)
    – K3---rnc
    Sep 25, 2015 at 22:37

Hey I had a similar problem. In my case, the laptop would be stuck on that screen most of the times. At other times, it would startup and work absolutely fine. That meant the Hard Disk didn't have a problem, it was something else.

Today I went to the Lenovo service center a second time for this problem. Last time he told me to back up my data as they may have to re install BIOS.

I went today, and he tried to enter the BIOS settings using a HD of his own. In that he found that the Boot from setting was selected to WiFi first.

Change that to HD first and the problem will be solved. Another option is to try to start it in a WiFi free zone. :-)

EDIT Finally I found out that the real issue was with the CMOS battery. In the service center this time - when I faced the issue for the umpteenth time - I told them this has been an issue since a long time. They tried to test in every way possible but they could not find an issue with the motherboard or RAM or Hard Disk or anything. Finally they just followed a regular servicing process, where they clean the internals, and remove the CMOS battery and place it back. It turned out that doing this with the battery solved the issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.